Wyze ignoring video/notification issues with Video Doorbell

I’ve opened multiple tickets with Wyze regarding a Video Doorbell that I installed, the first was three weeks ago. It’s been over a week and half since I heard from them last. I figured I’d try posting here to see if anybody else has had this issue and might have a solution. And maybe somebody from Wyze might help solve my problem instead of ignoring me.

I installed the Video Doorbell and the chime, etc, is working, but it rarely detects events and when it does, videos fail to upload to the cloud. I set ‘motion detection sensitivity’ to 100, which is the only setting - except making sure notifications, etc, are enabled - that looks configurable.

When an event is detected and I try to play it back in the app (using iOS app), then there’s a popup that shows “Failed to upload Event. Please check your WiFi connection.”

I have other Wyze cameras that work fine.

Here’s what I tried:

  1. Delete/remove the device, reset, and completely remove power for a few minutes. Then added it back and it still had the same problem.
  2. All firmware, etc is the latest.
  3. Create support ticket with Wyze and upload logging info.
  4. Wyze suggest I reset my WiFi, which I was skeptical would make a difference (I have no WiFi issues and can stream from the device live). I did this anyways and it didn’t work.
  5. I had a Cam+ trial with this camera (which never worked). I tried removing the Cam+ trial from the device and it didn’t make a difference. The trial has expired at this point so I don’t think it has anything to do with Cam+.

At this point, Wyze has not been helpful which is disappointing. I have a defective device and their customer support is lacking. I have many other Wyze device and fortunately, they work fine.

I’m wondering if anyone else has seen this issue? And hopefully someone from Wyze can chime in and help get this issue resolved.


I don’t have much to add other than I am having the same exact issue. All of my other cameras with Cam Plus are working as expected but the doorbell won’t record an event.

Same here

Same problem. I submitted a ticket to no avail. Maybe Wyze is overwhelmed due to the number of products released recently especially since a lot of them are more complex than the original Wyze cam, May be growing too fast and relying on customers for QC. It has happened before to other organizations. As an aside now looking at more established smart thermostats offered with rebates by my utility company since the Wyze thermostat appears to be problematic.

Has anyone had success in getting this issue fixed?

I gave up for a while and now have another ticket with Wyze. They’re not providing any help in getting the issue resolved at this point.

When I first got the doorbell, it worked great. Then it stopped notifying on motion or even a doorbell press… Also reached out to wyze and have been ignored. Sadly, I have issues with other products from Wyze - cameras not recording on SD card reliably, which I chalk up to ‘you get what you pay for’. I like wyze but won’t be spending more money on them until they step up the support and product quality.

So I should add that I set the door bell to factory settings and it seems to be sending notifications again…

Opened 2 tickets regarding the event video upload issue, they say they are working on a solution but don’t have ETA. I also have cam plus for my doorbell, my person event notification is working, only misses notifying me like 1 out of 10 times so my notification experience is better than yours but yes they do have to fix these 2 things before it could be recommended to others.

I uploaded many device logs, screenshots, timestamps etc. Only to be told that dev team is aware of the issue and they are working on it, God know when it’s fixed

My doorbell has never worked. They replaced it and the new one has the same problem. I suspect it’s an issue with cloud support on my account.

I opened multiple tickets, uploaded logs, etc, with no help. Only told dev team is aware of the issue and working on fixing it. Not sure I believe them.

Same problem here. It just happened a few minutes ago. I received a notification about 5 minutes after a person was at my door. The chime didn’t “chime” and the video took about 10 minutes to upload to the cloud. The person then called to see if I was home. I have a doorbell camera and a visitor has to CALL ME to see if I’m home. RIDICULOUS. Wyze keeps getting worse. But hey, they have Light Strips now. If I had to do it all over again, I’d go with all Ring cameras. Cost more, but they work. I still use the first one I ever bought. Never lets me down.

I had to reopen my ticket, since Wyze automatically closed my old one without resolution

Here’s the latest response: “ As much as I’d love to help, we do not have an ETA for the resolution just yet. I know it sounds rather not appealing, but I hope for your patience as our team is actively working on a solution for cloud-related issues. ”

I’m going to look at the Ring doorbell. I’ve been trying to get this working since last February and it’s never worked for me.

At this point, I have little faith that Wyze will ever fix the problem.

i have had similar problems/lack of support. i am not getting any notifications of doorbell button press. i do hear the chime but that is all. frustrating.