2.5.33 Android Beta App is released :-)

Dear Wyze Beta Testers,

This is Wendy, the release manager and technical product manager from Wyze. Today, we are happy to share our 2.5.33 Android Beta app with you. In this release we have:

  1. Fixed video lag issue in livestream and playback
  2. Fixed an app crash bug in group view on some Android devices

Dear Beta Testers, Wyze welcomes your feedbacks on this Android release. With your help, we can then make our products better and better. Thank you very much!



I am one of the android users having performance issues.

This beta release appears to have gone the wrong direction for me. I am getting extremely choppy video - as in one frame every 1/2 minute. I am using a Samsung Galaxy Tab A.

The app has also crashed with ‘app not responding’ message - or some such.

Camera I am testing is set at 360P. I set cameras down to 360P when the lag happened on SD.

I will leave this rig as is in event someone wants a log. I i will need a reminder how to produce log and send it.

After that I will go back to prior working version and lock tablet not to do updates.

Report submitted with log

1 Like


I let the tablet set there with the near frozen screen. After about 90 seconds to 2 minutes the screen started updating with only about a 1 second lag.

Until the time the screen started displaying normally, the app acted like it was hung and the tablet was bogged down.

1 Like

could you please also send me a log to wxi@wyze.com? I will have our developers look into it. Thanks.

Forwarded log to your email.

FYI, I have repeatedly started/stopped the beta app and it seems to be running fine now.

That said, it was pretty badly behaved after first installation.

Thanks for letting us know! Wendy has pulled the log and is forwarding to our dev team now. Thanks for the help, we will follow up as we have more info!

I just installed 2.5.33 on Android 7.0 (Moto G4) and it’s playing 1 second of video every 5-10 seconds. I can’t say for sure if that’s worse than before because I’ve been viewing in 360p for so long. I’ll see if it settles down after a while or try @wcodey’s method of repeatedly starting/stopping the app and see if it helps.

Edit: tried restarting the app a few times and then let it sit live streaming for a minute. Now it looks like the seconds are ticking by at roughly real-time but the video is delayed by 25 seconds. Audio seems to be roughly in sync at only 2 seconds behind.

Thanks for reporting this. Could you please send me a log at mstoneking@wyze.com after experiencing the delayed video feed?

I will if it comes back, but today I opened the live feed and it’s back to real-time with just a few seconds delay :thinking:.

I assume this version was tested for this issue before release and you found that it addressed the video lag, so it was surprising when it actually made it worse. Now it seems like it actually did address the issue, but it needs a solid few hours to “settle in” after being installed. I’m at a loss to explain that, perhaps a new library triggers Android to rebuild its cache which causes performance issues initially?


Exactly. Immediately after installation of 2.5.33 performance was much worse.

For me, letting it sit there a bit and just run in its worse state (2 frame/min) the app snapped out of it and started running as one would expect with SD video.

FYI, just tried another test - tablet power off and restart. Performance was immediately good even after a power off restart of the tablet.

It was a weird behavior. If that rolls to a lot of users it might be a bit chaotic for support. :slight_smile:

1 Like

I didn’t see that when I installed it
Initial testing the beta app V2.5.33 , Samsung S7 , Android V8 , firmware
No lag time , right off the bat, it’s set to HD

Fixed the video lag issue for me, Droid Turbo 2. I’m still having an issue with time lapse video playback. I get a message “Your device needs to be on the same Wi-Fi Network as the Wyze Cam…”, when trying to play. I use my phone as hot-spot for the cams and previously could play time lapse.

How do I get the android update?

1 Like

I Tested beta app V2.5.33 on Samsung a S 4 Android V5 , it works a lot better than V2.5.30
Go to the link , follow the instructions to become a beta tester , after awhile , it might take an hour or so to show up ,. go to play store and you should see the beta app you can update to it


I switched to the production App 2.5.30 a few weeks ago when the then-current Beta App became too unreliable for me. And, 2.5.30 was no better: frequent crashes into either an all black or all white screen, numerous attempts to connect to a live stream particularly on V1 cameras, playback mode failing to display stored video. Yikes! So, I took your advice and returned to Beta with Android 2.5.33 and it does perform much more reliably than 2.5.30. Connections to live views are quick, playback functions properly. I did experience one crash, however to a black screen, but this time the App reverted without the need to clear its cache first and then manually restart. Overall, my Samsung S4 on Android 5.0.1 is happier with the latest Beta App. Thanks for the nudge to get re-aquainted with the Beta App.

1 Like

When I first installed 2.5.33 on the S4 , it was not working as good I had green bars and couple black screen crashes , but after a bit the green bars went away , it smoothed out and started running pretty good.
App 2.5.30 was a total joke on the S4 , V2.4.82 runs good on it

I was one having issues with 2.5.xx on my Samsung J7, running android version 6.0.1, so i had to go back to 2.4.82. I decided to try the beta version 2.5.33, and everything is running very smooth, I only have cameras, so I can’t say anything about bulbs, sensors, etc. There is a tiny bit of lag once in a blue moon when watching live stream, but maybe for a couple of seconds, and it clears up.

Hi Wendy. I just became a Beta tester. Beta v 2.5.33 is such a HUGE improvement for my Android 7.1.1 Lenovo tablet over the in-production version I was using, that I deleted my very negative review of my 4 Cam Pans! Instantly upon install, the Playback’s Forward and Reverse buttons seems to be working correctly. And just like it used to, if I zoom the Playback’s timeline to expand from showing minutes, ie 3:21 3:22 3:23, to minutes & seconds, ie 3:21:00, 3:21:12, 3:21:24, 3:21:36, I can actually reposition pointer within the timeline and go directly to another second, ie from 3:21:05 I can jump to 3:21:47! When there is for example a 4 minute continuous block of time highlighted & greened out, it is very important to me to be able to reposition instantly to different seconds within that block, instead of having to watch the whole 4 minutes.

This beta should save me 1 or more hours each day of reviewing footage.

I had all the same problems mentioned on here, and it was so very frustrating I considered junking my 4 cameras and buying something else to go along with my 2 hardwired Ethernet Amcrest cameras. I have been assaulted twice and hit 7 times, and death threatened 3 times, in front of my front door by my upstairs pos neighbor, so these cameras along with my body camera I use when I walk out my front door are literally life and death for me. Every day I am constantly reviewing the footage from my cameras, and taking photos and videos from the footage and downloading to send to my landlord.

1 Like