Wyze Watch Firmware Versions 0.3.68 and 0.12.41 Released - 4/28/21

EDIT: The Wyze Watch 44 mm 0.3.68 firmware has been paused while we look into the cause of the “Core Data Missing” issue. Sorry for the trouble and thanks for reporting the problem!

Howdy, Forum Friends!

Wyze Watch 44 mm firmware 0.3.68 is releasing with bug fixes! Wyze Watch 47 mm firmware 0.12.41 is also releasing with the ability to rearrange and toggle applications such as the cycle tracker and experience improvements. :watch:

Read our Release Notes:


Great news! Downloading now…

Hi @WyzeGwendolyn, there seems to also have been a thermostat update last night (v1.1.7) for which there are no release notes. Also, there have been two Sprinkler firmware updates (1.0.2 and 1.0.3), neither of which had their release notes posted. Would you happen to have more information on those?

Wyze typically only posts version number changes in the release notes area for public releases available to all. If you are using a Beta app, or even a production app set to receive Beta firmware updates, then you will only see those Beta change notes posted in the Beta area: Beta - Wyze Forum

For your specific version requests:

Thermostat Firmware Version: 1.1.7

What’s New:

  • Adjusted the temperature correction formula to improve accuracy
  • The heating stage difference is reduced from 5F to 4F
  • Fan activation delay is improved
  • Coast to Cool is 30 seconds now
  • Added a new Fan Cycle setting that matches the app
  • Removed Fan Cycle from the device user interface

UI improvements:

  • Fixed a bug that caused the thermostat to show as offline when unplugged and reattached

Wyze Sprinkler Controller Firmware Version: 1.0.2

What’s New:

  • Added support for emergency water shutoff

Suggested Test Areas:

  • All areas

Firmware Version 1.0.3

What’s New:

  • Fixed a bug that interfered with physical button function

I did the upgrade on my watch 44 today and now my watch Durant work. It stuck on a screen saying core doesn’t missing. I can’t reboot, or do anything with it. I need help please. I just got this a few days ago.

Hmm… interesting… I was at some point using the beta app but I left that a couple of months ago, so I was certain that that wasn’t it. But it turns out that somehow I got re-enrolled again, so yeah, that was it. Thanks :slight_smile:

1 Like

You can do Beta firmware updates with the production app now too, so if you don’t care about the Beta APP updates, you can just use the production app.

just go to the Account tab > About > Beta Program on the production app, and you can set which devices you want to receive Beta firmware updates on (same as the way the Beta app worked for those).

Yeah I saw that I did not have the beta app, but I was testing the thermostat, the sprinkler and the vacuum, so in hindsight that makes total sense.


The update bricked my 44 watch. I’m on Android and the app was fully updated at the time of the watch update and the watch was given full time to complete said update. My watch screen is now locked on a screen that says “Core data missing, please connect the Wyze App to upgrade”. I have tried removing the device and adding again but nothing. The watch is now a paper weight.

Sorry to hear about the core data missing issue! Please contact customer support. I’ll escalate this to the team.

Wyze Customer Support



How do I contact them? i’ve been looking all day/night. is it the customer number that is during certain times?

i’ve been trying to get help with the website and nothing. is there a number to call or email?

(206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT


The Wyze Watch 44 mm 0.3.68 firmware has been paused while we look into the cause of the “Core Data Missing” issue. Sorry for the trouble and thanks for reporting the problem!

1 Like

@lisa6, just in case the website wasn’t behaving as expected, could you please tell me the path you took that wasn’t working for contacting support?

i was typing in watch 44 upgrade fail, watch 44 upgrade locked phone, core data missing and other questions similar and it kept showing me fuzzy watch face issues and lots of camera issues. once it even told me that the watch doesn’t show the weather.

Watch 47 battery monitoring bug after O.12.41 firmware
Hey Gwendolyn, I charged my 47 Watch on the 27th, one day before your O.12.41 firmware update. Right after it, my watch battery level indicator became stuck at 41%. It has never remained so fixed previously. The 41% figure is unexpectedly low based on the elapsed time since the charge. Is there a bug in the new firmware?

EDIT: There is definitely a bug in the O.12.41 firmware related to the watch’s battery level monitoring. My 47 still indicates 41% in both the app and in the watch. It hasn’t changed for a few days now.

After the update to 0.3.68 on my 44, it looks like Notifications are broken. Haven’t had a Gmail notification successfully pass through yet. I’ve restarted the app, reconnected, made sure the two are syncing etc.