Wyze Watch 47 Notifications

I have a One Plus 7T, and I am not receiving any notifications, hoping another One Plus user has had the same issues. I’ve followed all of their troubleshooting techniques and have submitted two logs to Wyze support with no solutions.

Any help is appreciated!

I’m on android and notifications don’t work for me either. I get calls and texts but it does not display contact information and no other app notifications work.

I guess you get what you pay for. I’ve had issues with other Wyze products like the outdoor cam. At least that is improving. The watch is a nightmare.

Before bashing the watch (and starting a new thread) try searching the forum, there are several threads with the fix (within android settings)

1 Like

Wyze fanboy… I’ve reviewed those threads. If you have nothing constructive to add to the conversation, stay out of it!

Haha, better than being a Wyze hater…but you’re still buying their products so…

If you’re not getting notifications, it’s something on your end, not the watch or app.

Here’s your constructive addition…Not all notifications work on wyze watch - #18 by Ken.S

I’ve the same problem - early on I tried everything that was suggested here but could not get notifications. It tells time, gives a heart rate, came with a band
AND has FW Version 0.12.37, maybe they will get some of the thing working if they get to FW version 1.0

Not sure which phone you have, I have a Pixel 5. After setting what @Ken.S provided, make sure your permissions are set to allow SMS and other options. By these not being on, may cause issues with the notifications. In addition, make sure you set the app to run in background, what is interesting to me is that I do not have the “Running in the Background” selected in the app, the Watch actually enforces it even though mine is not checked.

Here is the image of what permissions are set on my phone

Here is an image of how I have the Battery set as it indicates it needs to be set to run in the background. I actually turned off the Adaptive battery option for the Wyze App.

I’ve been through all of this with Wyze support, including sending logs with no resolution, Nothing works. I was hoping someone with a OnePlus 7T was having the same issues and was able to solve them.

I have a one plus 7T and had the same problem. I read on an Oneplus forum go into battery optimization on your 7t and turn off the battery for Wyze. it worked for me and I’m now receiving text on my Wyze Watch.

You may be experiencing the same problem I had. I had “Text Messages” turned on on the “Notifications” page of the Wyze app (on my Android phone) but still wasn’t getting text messages on my Watch 47. I finally tapped on “Other Applications” (at the bottom of the “Notifications” page on the Wyze app) and scrolled down and found that my text messaging app (“Messages”, which is the standard text messaging app on my Google Pixel phone) wasn’t turned on. I turned it on and the text messages immediately started appearing on my Watch 47. So, you might want to check there and see if your phone’s text messaging app is activated there.

I have to hand it to Wyze Support they were finally able to fix my issue by pushing through a firmware update. Thanks, Wyze you’re keeping me as a customer. Keep it up!

neo, I’ve been following your comments. I have a 7T also. I’m receiving texts by turning off battery optimization for Wyze. I still have not got the email to work with Outlook or Gmail. Did this firmware update help this issue? Or do you have any other suggestions?

47 Wyze Watch



Yes, the firmware update did enable all notifications. However, I have this persistent notification that the Wyze app is running in the background and I’m afraid to turn it off for fear the notifications will no longer work.

If you’re still having issues context support. It may take them a while but eventually, they will resolve your issue.

1 Like

The latest firmware update broke the notifications, so I no longer receive them. I take back what I said about Wyze’s support. They’re a bunch of automatons that get lucky once and a while.

After contacting them again they didn’t even read my message just sent me their script.

FW update to what? The watch?
I’m running 0.12.43 and it fixed most of my notification problems,
Didn’t fix things like the FedEx guy pulls up in the driveway, brings package to door, drives away , then I hear the notification.