WYZE Vacuum - Wont clean where a moving box once was and also only cleans one room perimeter, not area - weird

Have asked Wyze Support some these questions for the last 10 days and NO response. Usually WYZE is good, Support on vacuum isn’t so good. Guess I need to be patient as Wyze usually has good support… Anyways…

I have my entire house mapped, Vacuum works quite well. Using latest app and firmware as of 2/7/21. I have used virtual walls to “split” up my floor plan as we have an open floor plan.

Problems / Questions:

  1. We had a moving box (2ftx3ft) when we mapped the entire house sitting on the floor against a wall. the mapping took a long time as our first floor is over 3,000 sq ft. We moved the boxes but on the map you can see a faint shaded in rectangle area representing the moving box. Have run the vacuum 15+ times and it still avoids the location where the box was originally placed but the box has been moved a long time ago. How do I get the vacuum to include this area without remapping?
  2. Does anyone know the difference between RESET MAP versus REMAP. I see it on the app on two different screens. Would rather not delete my rather intensive map.
  3. We have one room that worked perfectly fine for many weeks. However all of a sudden now the vacuum only cleans the perimeter/outline of that room, It used to take about 15 minutes to clean the entre 200 sq ft room zigging back and forth, but now just takes 5 minutes to clean the perimeter, just one quick circle around the room. Full battery charge, nothing stuck in the wheels, sensors or rotating brush. Weird, just cleans the perimeter of the room and then returns to base saying Cleaning Complete., worked fine until yesterday. I changed nothing and no furniture moved.

Any thoughts / suggestions are truly appreciated. Everyone stay safe and healthy!

In my experience the remap deleted the previous map so it’s really the same thing as delete map. Unfortunately you will need to remap and then recreate rooms and walls afterward again. I have done this a few times when I chose to move around the charger location a couple times. On a positive note the mapping/remapping function got loads better after the last updates so it will map you large area pretty quickly, then you can add the rooms and walls before cleaning.
Good luck


So I had the same problem as #3. Wyze would only do the perimeter and say the job is done. Scheduling the room again solved the issue. It must be some kind of glitch because literally nothing changed. No humans or pets. Furniture wasn’t moved. But at least I didn’t have to remap entire first floor.