Wyze v2 RTSP Shows Few Frames then Stops

I have had a v2 camera running RTSP firmware v for about a month now. The RTSP function has been working flawlessly, and the only issues I had were the proxies to transcode to HTTP video.

The setup has been powered by a Raspberry Pi 4+ Running OctoPi (Connected to 3D Printer), the camera was just plugged into the USB port. Under/Overvoltage was never an issue to or from the Pi, and it was working like a charm. Furthermore, the camera is on a dedicated VLAN/WiFi network that was only for machining stuff. This VLAN has no firewalls between it and my client’s VLAN, nor are there any routing/latency issues.

Today all of a sudden I stopped seeing the stream coming from my HTTP proxy. The video was still working like a charm on the Wyze app, so I figured this was an issue with the proxy itself. I did some troubleshooting but didn’t get anything online, tried another package to stream it, and so on.

I checked the RTSP stream directly using VLC (which always worked previously), waited a very long time (30 seconds) and got about 2-4 frames, then it freezes and usually just becomes all black with no more updates.

Nothing worked, so I unplugged the device, and moved it to an actual outlet. There I turned off RTSP, rebooted the device, turned on RTSP, tested, regenerated RTSP link with different credentials, tweaked image cache settings on the VLC stream, and put the device on a different WiFi network (right next to the access point). None of these changes helped at all.

When pinging the device, latency is around 10ms but spikes to 100 every once in a while. As soon as I start trying to access the RTSP stream, the latency spikes to 200-600ms and stays in that area until I stop pulling the stream. Maybe the little guy just needs a break, but I don’t want to give it to him. I kept it unplugged for around 30 minutes without any changes.

Any help would be appreciated!

Well, I left the Wyze camera unplugged overnight and this morning I turned it back on and decided to check if RTSP was working.

It was, so I guess it just needed a break. I would’ve figured a few hours would do the trick but something else must have happened in the meantime. Hopefully nobody checks out this thread in the future, because there is nothing here to help you. Except maybe turning it off for a full 12+hours.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.