Wyze thermostats just not working properly

I have two heat pumps that I installed over 11 years ago and I maintain both. Recently, one thermostat was acting up so I decided to replace both with the Wyze thermostat. Installation was very simple and both worked great for about two days. Temperatures are set at 65 for heat and 73 for AC. Differential temp is set at 1 degree. Both thermostats have “Home” and “Sleep” mode set and the “Away” mode removed. If I leave home for an extended time I will reset thermostat manually. Both thermostats have decided to have a mind of their own. Both change differential temp on their own to 2 or 3 degrees difference. Needless to say, rooms get a little warm until I turn on AC manually by clicking the “Restart” button in the app. I have reinstalled both 3 times and both have latest uodates. When I reset the differential temp back to 1 degree, neither thermostat will activate heat pumps until I click “Restart” switch. After house cools down, both units stop as they should but, when it temps rise and units should come back on, they don’t (most of the time). It’s about a 50/50 chance that thermostats work as they should. When I go to bed, room is at 70 degrees (Nice). I wake up to hear air coming out of vents from air handler and outdoor unit not on. I reach for phone to manually click “Restart” and outside unit starts. All wires are installed as they should and I am pretty good at tracing electrical or component problems. This really has me stumped. I have no problem with the wifi and I can connect to thermostats while away from home. It would be strange to replace both but, they were both purchased at the same time and there could be a problem on the manufacturing side. If anyone has a suggestion, please summit. I will continue to use these for a few more weeks and if I can’t figure out what the problem is, I will replace both with another brand. I do have Wyze cameras connected to the same network but I don’t believe they would interfere with the thermostats.

Welcome to the Wyze User Community Forum @doitright! :raising_hand_man:

A few questions…

In the Temperature Preferences, you should be setting the preferred temp range for all three states. I don’t know of any way to “remove” the Away state.

These temperature set points will be respected, with your temp differential, in your case call for HVAC 1° above\below and stop HVAC 1° above below, unless you have a schedule that states otherwise. Schedules overrule Temp Preferences. If you change the temps in the Preferences, it does not update Schedules. If you change the temp in Schedules, it does not update Preferences. Only when you first create a Schedule will it draw from the Preferences. After a schedule is created and saved, all changes to the temps for the Schedule must be done to each individual Schedule time block. The only way to run on Temp Preferences only is to delete all schedules. This would require you to change all states manually.

Also, what is the Behavior set at. This setting will change how the thermostat operates. I have mine set to balanced and it has been operating efficiently since installed and respects my Temperature Preferences and Differential. I run no schedules but have my thermostat state changed by automations based on when I get home, leave, and go to bed.

Doing this will be overridden by the thermostat should a Schedule time block occur. The only way to avoid a schedule running and changing the manually adjusted setpoints is to place the thermostat on Hold after setting it manually.

Check your schedules to make sure all the temp settings reflect what temps you want and when you want them. Also check your Preferances settings.

1 Like

Thanks for your reply. My Preferences for both thermostats ae set 65/74 on Home, Away and for Sleep it is set for 65/70. Sorry, I deleted Away on Schedule and not in Preferences. my schedules are set at Home 65/74 and Sleep at 65/70. The Behavior is set at balanced. I have not tried to set a Hold yet but I am assuming it will override schedule and preferences until the hold is removed and temps will be in the range set and units will come on and off as the hold temps are reached. As I am writing this, I look at the app and the upstairs unit temp is at 76 and it should be cooling to 74. That unit has been running well all day and has decided not to come on as scheduled (cool to 74). I had to click “Restart” again and upstairs unit starts working again. This morning the differential temperature on both units went from 1 degree to 2 degrees and I did not make those changes. Thermostat just decided to do that on its own (?). It’s just my wife and I and I am the only one with the app on my phone and the only one to control the thermostats. Is there a possibility that there is a time limit from when the was has reached the set temp and automatically turned off by the thermostat to when it will come on again even when temp rises above scheduled temp? Say 10 minutes or so? Still trying to figure these things out and I do appreciate your feedback. Both units seem to be working better today than they did the last few days. Only had to “Restart” upstairs unit twice so far today but that was before I realized the differential temp was changed from 1 degree to 2 degrees. Reset both thermostats again and saved setting again. Will see what tomorrow will bring.

I have never experienced the settings changing like that on their own. Mine has always remained rock solid. What are your Firmware versions?

Yes. There are safety lockouts that should prevent it from starting up again too soon. But when this happens, you will usually get a safety countdown and it isn’t that long… Maybe a couple minutes.

Even with the differential set to 1° @ 74, it should be coming on at 75 and cooling to 73. It is going to take more than a couple minutes to regress and restart.

Another question… Are you using any Remote Room Sensors with the Thermostats?

Firmware version was updated after installation to 1.2.7. Yes, I am aware of the safty lockout and have seen it on app a few times. Earlier when I mentioned that the upstairs unit was on (air handler only) and not the outside unit (AC compressor) I clicked the “Restart” while unit was on and the outside unit (compressor) immediately started and it began to cool down. Thermostat was set to 74 and temp upstairs was 77 and the only thing running before I hit restart was the air handler. Units have been working as they should for the last 4 hours with no problem but as usual, this will change. What make these thermostats work great for 4 to 6 hours and then mess up for 4 to 6 hours. It’s not the schedule. Something changes the thermostats from working to not working at all and it is not the same time frame each day. I will continue to narrow down the problem and if I can’t find it in a few days, I will replace with a different thermostat. Thanks for the feedback. I purchased these thermostats about a year ago to use on new heat pumps after installation. However, these units still run great and I will continue to use them until they just give out. I put these in myself and feel comfortable about replacing them with newer models when the time comes.

I have a Gas Pack unit, forced air gas heat w\ AC Heat Pump, and the T-stat has been great since installation.

I am tagging in @speadie who is great w\ these thermostats. Perhaps there is an installation selection or wiring selection that would make a difference. Always better to get a different perspective.

The fan running but not the outside unit running is possibly a result of coast to cool settings in the app not predicting the cooling capacity of the system properly. Might try turning that off. I’m not sure if the AI features ever got properly implemented, maybe it did, and the reason it’s getting better is that it is learning how much your system cools when coast to cool is activated. If you’ve got it set to 1 degree differential, you might as well set it to max comfort and disable coast to cool as well.

1 Like

The coast to cool settings in app is not on. For the last 8 hours, both units are working great. I did not have to do a “Restart” on either thermostat. There seems to be a learning curve built in on these thermostats or there is a faulty solder joint. I have repaired many circuit boards with faulty soldered joints. This seems, to me, to be the problem as a bad solder joint can make or not to make contact due to temperature changes and as that contact continues to move, the problem can get worse or better. I too old to dig into that board to see if that is the problem but it seems to fit since both boards were purchased at the same time. Wyze ask me to send them a log of each thermostat and I looked into the app and there is no log data to be found. I will contact them again and ask what where is this data they want. That would be great if each unit had data that would pinpoint a problem and someone would be able to tell me the real problem. I have that with a laser cutting machine that will tell me of any problems so I can fix usually myself. There are many possibilities and I started this thread to let others know not all HVAC systems will work with this Wyze thermostat. I have split systems (heat pumps) that have a heat strip for auxiliary heat if it gets too cold. I tested the app to make sure the heat strips would work with this app and it does even without a jumper. Whether it will work properly or not, then that’s a question that will be answered later. Thanks for the input.