Wyze Thermostat - Wiring Q's & Issues

Couple things.

First - Setup is telling me I have a missing wire. It’s in there good. I want to pull it out and re-insert it, maybe it’s not making a good connection. How do you remove the wires? I can NOT do it.

Second - Setup is telling me I’m missing the G wire (it’s there), but the error message says “If you’re missing O/B, it may affect the control logic.” Well, I didn’t have an O/B in my old thermostat. And, it didn’t tell me to connect anything to O/B when I was wiring the Wyze. I “tried again” a bunch of times, then finally “skipped” and went on to testing. The heat tests (2) didn’t heat, and the cool test didn’t cool. Fan turned on, but no temperature difference.

do u have a heat pump? your old tstat has 2 sets of labeling, conventional & heat pump, u have the wyze tstat wired as conventional.

All the wiring for the old thermostat were connected to the “conventional” section. So, that’s why I selected conventional. (see pic below)

The HVAC unit is a 2012 Lennox CBX26UH-042-230-2, if that helps.

I’m not a hvac tech to know if your unit is a heat pump or not, but I believe if u look at the wiring block, you insert the wires only from the top. the labeling depends if u have a heap pump or conventional. many others have posted pix of the same tstat & chose conventional when they actually had a heat pump.

maybe @speadie will know if that system is a heat pump.

1 Like

It might be a heat pump. The outside unit is a Lennox 14hpx-042-230-18. Google seems to indicate it’s a heat-pump.

However, if I delete the device and re-run the setup, it doesn’t appear that the wiring should be any different.

All the wiring for the old thermostat were connected to the “conventional” section. So, that’s why I selected conventional. (see pic below)

The HVAC unit is a 2012 Lennox CBX26UH-042-230-2, if that helps.

if u have a heat pump the orange wire should be connected to O/B, and the white wire W1…on the Wyze tstat

Didn’t seem to work. I moved orange wire (W from old tstat) to O/B and the white wire (W2 from old tstat) to W1 on Wyze.

I removed the tstat from the app and reinstalled.

I still got the error that the “G” wire was not connected. Re-tried a couple times. Then I ‘skipped’ and ran the tests. It seemed as though phase 1 of heat did not work – blew room temp air. Phase 2 seemed to warm up a bit, but only felt marginally warmer. Cool seemed to be air temp, not particularly cool. After the test, I turned the system “off” in the app. After 5 minutes, it did not turn off, so I turned off the breaker.

Other issues of note: the app would not allow me to install the latest firmware. Kept getting an error immediately upon trying.

What do I do now?

Ken S -

By the way - thanks for all the advice and help. Sorry if in my replies I came off as though I was “demanding”. I thought you were support replying to my e-mails and didn’t realize you were a very helpful user generously replying to my forum post.

You rock!

1 Like

You have a heat pump.
When you re-added it to your app, did you tell it that you had an O/B wire? Just moving the wire wont work, you need to tell the app what wires you have during setup. Tell it you have the following wires:


If, during testing, it blows cold air during the heat stage or warm air during cool, then you need to go to settings>advanced and select “swap hot and cool”

Ignore any “wire not connected” errors, the wyze app is not very reliable in detecting wires.

1 Like

speadie -

Thanks so much for that. I’d love to tell you that worked (and I suspect it will, now that I’m starting to understand the setup better, this makes perfect sense). But, I still keep getting the notice that the G wire is a “missing wire”. It’s in there good and tight. Support seems to think it’s a bad terminal.

I’ll come back and update once that gets figured out, in case this can help someone else.

Yes, the wire detection feature leaves a lot to be desired. You should just be able to “try again” and then skip the error- it shouldn’t be an issue.