Wyze Thermostat W2 2nd Stage heating not coming on

So, I have the thermostat installed, it powers on, and during the test, phase 2 of the heating does not come on. Originally there was a 6 wire thermostat with no C wire connected. It was only Y,Y2,W,W2,G and Rc. So I tried the C conversion device, and everything worked, except stage 2. So I ran an 8 conductor, and hooked up the C wire as well. As it stands, this is how the thermostat is hooked up:

The Rc wire runs to a black wire that runs through an overflow shutoff and back to the R terminal on the board.

When it switches to stage 2, the fan still runs, but the heat turns off. Any ideas?


Here is a photo of the inside of the unit.

That looks like a Lennox Furnace, what model is it?

It is an SL280UH090V48B-04, running on propane.

Awesome furnace btw…

Your wiring looks correct on both the furnace and Wyze thermostat. During setup, did you choose “Gas” for the type, then “Forced Air”? Push the knob and hold for 10-15 seconds to prompt a reset of the thermostat. Delete it from your app, and re-add it with your new wiring and see if it detects the correct wires.

I did that, and re-added it in the app. Still the same issue.

Update: I just saw another post that showed setting stage 2 as electric, so I tried that, and it is now working. Is that ok, or should it be working properly with propane and forced air as stage 2?

What was your old thermostat?

The old thermostat was a 2gig GC-TBZ48. It had all of the wires the same, but no C-wire.

Thanks for props on the furnace. It was a pricey little thing.

Do you still have Stage 2 gas heat defined as “electric” to activate Stage 2? Is that working?

Stage 2 is still not working properly on they wyze. It should start with a stage 1 (W1) call for at least 15 seconds and then also switch on stage 2 (W2). This will cause most furnaces to switch into stage 2 heat. Right now, the wyze turns off stage 1 (W1) when it turns on stage 2 (W2), which confuses most furnaces and they just shut off.

Agree that is how the System Test is working. W1 working. W2 not. That said, I am noticing that after 30 mins on Stage 1 … my furnace is bumping into Stage 2 and off when set point achieved. I spoke to my HVAC installer, and they said that I could disconnect the W2 to thermostat, jump W1/W2 at furnace board, and let the furnace control W2 - w/ dip switch control of 10, 15 or 20min delays to W2. Or leave connect to the Tstat and let it control. So I have W2 connected to Tstat, and then after 30 mins, W2 kicks on. I haven’t checked if Wyze Tstat is energizing W1/W2 when this occurs, but assuming so. It must be doing something, but not sure if it’s intentional. @WyzeChuan is this correct? Thx!