Wyze Thermostat Sensor - Won’t connect

My new room sensor arrived. It refuses to connect. About every 50th time, it finds the device but after I click save on the naming page it doesn’t show on the sensor list.

Also there is a type-o on the connect page when you view it from a shared account. It says “You can not connect a sensor on a shared device”. It should say “cannot”.

1 Like

I ran into an issue as well. I did the following:

  • Performed a Factory Reset on the Sensor and removed the Battery
  • Deleted it from the App, if it is there
  • Restarted the T-Stat via the App Settings location
  • I waited a couple of hours (I was out of the house).

Then when I came home, I started one at a time (I have 6). Go to the T-Stat and click on the Pill Shape to get to the Remote Sensor Screen. Then put the battery in one sensor. Click the Green Plus on the App, Tap quickly the Pairing Button on the remote sensor and wait for it to connect. It could take a little time (but not too long). Name it. Also, make sure you are relatively close to the T-Stat during setup as it seemed to be faster.

Thanks for sharing your steps! I tried them and added a few to make sure everything was in the best state to pair.

  • Performed a Factory Reset on the Sensor
  • Replaced the Battery for the Sensor
  • Deleted and reinstalled the Wyze App
  • Deleted and Re-set up the entire T-Stat
  • Restarted the T-Stat via the App Settings location
  • Confirmed Apple Private Relay was off for the iPhone used to pair
  • Confirmed Bluetooth was on for the iPhone used to pair

Bad news - The sensor is still not showing :skull_and_crossbones: I am using an iPhone 12 Pro.

Hmmm, I am on an Android. Did test with my iPhone Xs and it worked as well.

I do know there is a setting on the iPhone which needs to be on, you may want to check the App and make sure Local Network is turned on. Not sure that is going to fix anything, but something to check.

I would also reach out to Wyze as it could be a defective device, calling has been better for me, but here is a link to the Support page followed but the contact info:


I bought a three pack. Got it to work by following some advice I received from Wyze Support:

  1. Only have 2.4 GHz turned on (I turned off the 5 GHz option) the wifi router
  2. Restart Router
  3. Once Thermostat reconnects (took about 10 minutes) go through steps to connect sensor.

I had no issues connecting the sensors after doing the above.

Although not in the recommendations, I turned 5 GHz back on and restarted the router. No problems after that.

Support has informed me that beyond this there is nothing more to do. I’ve submitted logs and was told to wait for the next firmware to fix the issues but wasn’t told what the issue was. They worked for 3 days then just stopped reporting in the app. Oh well.

I have a three pack. They all connected, but they do not update and when they are added to the comfort, I see a red exclamation point. I have reset all three and reconnected as well as reset t-stat…the sensors do not update at all

What is the red :bangbang: mean?

I have tried everything and can’t figure it out.

Unplug the t-stat display from the back panel and then wait a few second and plug it back in

1 Like

You helped me figure that out on Discord, thank you!

1 Like

Oh right , night to see you in the forum :grin: