Wyze thermostat lost FAN control option

hi. My thermostat worked well for over month and one (cold) night it stopped heating. Next morning I removed it and added again. Then the FAN option was gone (fan on, cycle, fan off) from both the unit and the app. The fan works when it heats, but I lost the ability to control it.
I have Rc red wire, Yi blue wire, W1 white wire and C green wire connected to unit. Did the fan wire get disconnected?

If G wire is for fan, is my C wire controlling the fan? Which of my wires control the fan???

When I swipe up in thermostat mode i can only see in “controls” the STATE and MODE but not the FAN anymore.

when using the C wire adapter, the tstat is getting it’s power from the G (fan) wire between the tstat & the adapter, then from the adapter to the control board, you have a connection for the fan & C terminals. Maybe there’s a issue with your adapter if you’re no longer able to control the fan. Only suggestion I would have is sort of power cycle the adapter by turning off/on the furnace

1 Like

Thank you for explaining this. I have reset the power, as well as the furnace and the issue is still there. I guess the furnace person is now needed :frowning:

before paying a repairman, I’d do a couple more things to troubleshoot.

  1. reset the tstat (press knob for 10-15 secs) & re-install to see if that fixes.

  2. reset tstat, then install right at the control board bypassing the adapter. You’d need a short piece of 5 conductor wire. This test is to make sure the tstat isn’t bad. If you now have fan control, the adapter may be bad, If you still don’t have fan control, the tstat may be bad. I’d contact Wyze support.

When you reset it what wires did you tell it you had, and what type of furnace did you tell it you had?
You need to tell it that you have a G wire and not a C wire, otherwise you will lose fan control.

Thank you for replies to this. Please see below the images.

The fan on the old thermostat was working before, so the wires were definitely connected properly. I got brand new thermostat now, so it’s doubtful both would be bad.

I have tried suggestion 1 with old thermostat.

I will have to try the suggestion 2 with 5 conductor wire, thank you for suggestion.

You stuck the wires in the wrong holes in the image. The wires go in the ends of the connectors, opposite the levers. the holes that you stuck the wires in are where the thermostat connects to the backplate.

There’s something wrong at that furnace board, the wire colors don’t match the ones at your thermostat at all,and there is no C adapter hooked up.

Also, if you reset it and told it that you have a C wire and not a G wire, then it doesn’t know you have a C wire adapter hooked up and will not allow you to control the fan.

I will try to correct it. Although like I said, the fan worked with this configuration in January… since I followed wyze instructions.

Check the male pins on your Wyze face plate side. I am not surprise there will be bent pins.

If male pin iss broken, you need to fix.

1 Like

Thank you for reply. Where is the face plate, is that downstairs in the furnace? (forgive my lack of knowledge of terms)

when you pull the tstat off the mounting plate, the pins are on the back of the tstat, the holes you put your wires into are the holes that the pins insert into. I can def see this causing issues, as those holes are not meant for both the pins & wires…nice catch @speadie

@Cluster I actually didn’t even see that you shared the link to another post. I thought you were just saying that you were all set. I just looked over this thread that you linked me to and the first thing that sticks out to me is that you don’t have a fan control wire behind your thermostat (if you do it is improperly labeled) If your furnace has fan control then it should have a G wire to control it. Without a G wire there is no way to control the fan. I see that on the panel for your furnace you do have a G wire connected. But i don’t see it on the thermostat end. Without that G wire fan control is not going to be possible. Back in January when you had fan control i would bet the wiring was different. if your wiring was setup exactly the same as it is now then the fact that it showed fan control may have actually been a bug and it shouldn’t have showed it, and that’s why it is gone now.

Thermostat wiring comes in either 3 wires or 5 wires not 4. So the fact that you have 4 wires behind the thermostat tells me that you have a missing wire in the wall somewhere. Try to find that wire

I’m going to put my money on the chance that the wiring is not correct. If it was me I would follow those wires from furnace to the thermostat. You can use continuity tester on each end of the wire to make sure you have the same wire on both ends of the run. Figure out what wire is actually hooked to the G terminal and what wire is actually hooked to the C terminal etc etc for the rest of the wires. I’m willing to bet one of them is not correct or is not ran all the way to the thermostat. Figure out what the G wire is and hook it to the G terminal on the Tstat and you should have fan control again.

But before you go and do that the other big thing I noticed is that your wires are not properly connected. They don’t go in the holes you have them in. Those holes where your wire are, are supposed to be for the pins on the back of the thermostat. It’s possible that having the wires there caused the pins to bend or break. Either way broken pins or not, if you don’t have a G wire you won’t have fan control.

Have you fixed the wiring since the picture was posted? If not start there. Disconnect the wires and follow them back to the furnace and make sure they are labeled properly and try to find the one missing wire. If you need better explanation of how the wires should be let me know and maybe I can get a photo that will show you the spot they are supposed to be inserted into.

After you get the wires traced back, labeled properly, and installed correctly in the backing plate of the thermostat then double check all the pins sticking out of the back of the thermostat. Make sure that the pins are all there and that none are bent broken or missing.

when u install the C wire adapter, the G wire is used for power connected to the C terminal…the Wyze tstat can still control the fan.

@Ken.S as you can see in the photos above @Cluster has a standard C wire on his furnace and is not using the C-wire adapter. So that would not apply. Without a G wire he is not going to have fan control.

if u read my comment you would know he is using the G wire connected to the C terminal, which is how you wire when u install the adapter


he has a brown wire on the C terminal at the furnace, probably going to the condenser

@Ken.S maybe I misunderstood what you were saying. If so I apologize. I was just trying to say that he does have a wire on his C terminal and is not using the adapter. So without a wire hooked to the G terminal on both furnace and thermostat he won’t have fan control.

Now that I relook I believe you were trying to say that if he installs his C wire adapter and uses the G wire for power to the adapter then he will still have his fan control ability. Right?

What makes you say he’s not using the adapter? My understanding is that he is. He stated he had fan control then it stopped working.

Yes, that’s how the Wyze thermostat works when using the C wire adapter, you connect the G wire to the C terminal on the Wyze thermostat then from the adapter to the control board, it’s G to G and C to C. This powers the thermostat and still gives fan control.

The picture of his furnace board shows he is not using the adapter.
Which really makes no sense- the wiring in his images don’t have any wires that go to the thermostat connected to C The only wire connected to C is a brown wire that goes to the A/C.
His blower fan would be running constantly with the way it is currently wired.

Agreed that clearer information is needed. I assumed that furnace picture was prior to install but who knows since he’s not responding. The fact he said he he had fan control and no wire on the G terminal at the thermostat further led me to believe he had a adapter

If you look at the picture you can tell there is no C wire adapter installed. The C wire adapter has all white wires and would be installed directly onto the board in the furnace so it would be visible or at least 4 white wires would be visible coming from the board in the photo if the C wire adapter was being used.

From my understand he said the fan control options were visible on the app and the thermostat. But never commented on wether or not he could actually manually switch it on or off. If it was wired the same way as it is now then there would be no possible way to control the fan. So the fact that it showed fan control was more then likely a bug and the controls would not have actuated the fan if he used them. The only other thing that makes sense is that the wiring was changed and was setup properly before and isn’t setup properly now.

Yes I do understand how the C wire adapter works and gets wired I was just misunderstanding what you were saying.