Wyze Thermostat Firmware 1.1.2 Released! - 3/10/21

Hello, Forum Friends!

Wyze Thermostat 1.1.2 is releasing today! This has improvements such as adding a 15 second delay between fan and heating, adding a differential temperature feature for greater control, and improving time zone calculations.

Read our Release Notes:


Nice update… I can’t seem to find the new differential setting. Although I’ve been known to miss things while looking right at it. :grinning:

I keep getting this error message when I tried to upgrade to version 1.1.2

My Wyze app is version 2.18.12


Resolved. After updating to Wyze App version 2.18.18 it updated Thermostat to 1.1.2 as well.

I have same issue, but app is updated


Android App version 2.18.18, and get “Oops, we’re sorry. it looks like the update failed.” How hard is it to release an update that will actually install?

Edit: Force-closed app and re-opened. Update failed. Deleted Wyze app completely, re-installed, re-logged. Update failed. Next step would be to delete device and try again, but I’d hate to lose all my heating/cooling data, schedules, and settings if it’s a problem with the update…

Edit 2: Rebooted phone but update still failed

Edit 3: Cleared app cache and re-opened app but still failed

1 Like

I have same issue. App updated , rebuted phone, power cycled thermostat. Get same error


Found it, I had to update the app as well as the firmware to see the differential setting.

Same issue. Fails to update to 1.1.2. App is version 2.18.18.


Also getting the Upgrade failed error. I’m running the latest Wyze app, 2.18.18, on Android 11.

1 Like

Mine won’t update either and I have the latest version of the app as well. I’ve rebooted my phone and it still won’t update.

1 Like

Same issue won’t update on my android or gf iphone.

1 Like

same issue here. Once after restarting the app, it actually started the update. Ran for 30 seconds, then went to the Oops Sorry Screen. I’m on beta software on the phone, so I have the latest application. The thermostat firmware is 1.1.1. It is trying to upgrade to a version above 1.1.2, but still having same issue. Will wait until tomorrow and see what Wyze does.

Found a fix for the failed firmware update. Go to the app and clear the cache. Then restart the app and the firmware update runs. It takes 2-3 minutes. The thermostat reboots and goes on line. The app on the phone still showed it was still updating for another few minutes and since the thermostat was working I finally killed the update on the app. Checked the firmware version on the thermostat and it upgraded and the app on the phone shows it upgraded correctly too.

I was so hopeful, still failed for me. Glad you got it working though

FYI, clearing the cache did not work for me.

1 Like

Same issue as others. Latest App (2.18.18) running on Android 11, tried the tricks others have, but his update will not install. Frustrating!!!

Same issue here. Latest App (2.18.18) running on Android - update fails

1 Like

Same issue as well. None of above “fixes” worked. Would be nice if we were acknowledged or some kind of update to issue.