Wyze Thermostat disable fan cycle

Ever since firmware 1.1.7 my thermostat randomly cycles the blower fan. Ideally, I would not like this to happen since I live in Florida and my AC ducts are in the attic its very inefficient in the summer to move air from in the house back through the attic and into the house.

I have the thermostat settings for FAN and MODE set to AUTO

In the advanced tab I have Fan Cycle set to the lowest setting which is 5 minutes

Not sure what else I can tweak to stop this from happening


You should be able to set fan cycle to zero. At 5 minutes, it’s going to turn on every hour for 5 minutes then shut off unless the system is on already.

I also have v1.1.7 and it turns out the 0min option is gone. Fortunately mine was set to 0 before, so it retained that setting, but if you had it set and updated to v1.1.7 it really does seem you can no longer set it to 0 minutes.

Maybe @Chuan can confirm? Are we missing a setting somewhere?

If your fan setting is not in cycle mode it shouldn’t matter what setting you have for cycle time. Released version 1.1.16 that I am running doesn’t have a zero setting either (mine is set to 15 minutes and lowest setting is 5 minutes) and when running the fan in auto mode it doesn’t cycle the fan so it would seem like there might be an issue with that beta version.

Is there any easy way for me to roll back and test?

Well, I guess I have to install my old thermostat. Basically, the AC runs cools the house down and then the blower fan runs just long enough to trigger the AC to kick back on during the warmest times of day. Created a pretty big power bill for me last month.

With the latest app update there now is a possibility to set the fan cycle to zero, along with the possibility to set the fan activation delay time when using the heater.

1 Like

Excellent reinstalled it and testing with fan cycle set to 0. Didn’t realize I had this device set to install beta firmware. Removed it from beta as well. I’ll update if I notice it occurring again.

Same thing happening to me ever since installed 1.1.7. Fan is cycling every hour even though FAN set to [Auto]. Tried changing to FAN [Cycle] then back to FAN [Auto]. Tried changing from MODE [Heat] to MODE [Off]. I think I recall Fan Cycle 0min/hr after firmware upgrade, I changed it to 5min/hr, and now the 0min/hr is no longer an option. I’m getting ready to install the old thermostat unless someone can tell me how to revert to previous firmware version. Thanks

Hey spider,

See if your Wyze app has an upgrade. Mine just got it a few days ago and now have an option to set to 0 is back. Which worked for me.


woo hoo 0min/hr option magically appears after Wyze app upgrade. Thanks @fritzstauff Also noticed Wyze removed FAN [Cycle] option from the Controls which now show only FAN [Auto] and FAN [On]. Actually I liked having FAN [Cycle] under the quick slide up controls. Now I have to dive into advanced setup just to enable cycling. My guess, it was confusing to non-power users so they hid the feature in the UI.

Hey Spidey,

Good find. I didn’t notice they removed cycle altogether from the control section on the latest update. It is kind of odd that the only control is hidden away in advanced. Now if only I get get the temp differential to truly set to .5 still seems to do a full degree which is not ideal for my fairly small ac unit.

@WyzeGwendolyn, please do the voodoo that you do and sweet talk the coder peeps into bringing back fan cycle back to controls. It was a handy option to have. I don’t always want the fan to cycle and having the option to turn it on and off from controls was convenient. Now I have to go into advanced settings every time I want to turn fan cycle on and off. Pwetty pweeze

I am having this same problem. Fan on Auto, even when the ‘Heat/Cool’ is in OFF mode, the Fan still runs according to the Fan Cycle setting, and unfortunately the min setting is 5min/hr, so the Fan is running 5 min/hr no matter what. It seems the Fan is stuck in "cycle’ mode permanently. (And yes, if I put the Fan to On, it doesn’t turn on, but still just runs following the Cycle setting). Is this a bug or something else? Any ideas?

Force an update to the Wyze app. Then it should offer 0min/hr as a choice just before 5min/hr.
To update using Android. Launch Play Store. Search Wyze. Tap update.

Now I see 0min/hr. Thank you spidey!!