Wyze Switch - Update Failed

I finally got around to installing my Wyze Switch today but the Update to 1.2.22 is failing for me. My current version is 1.2.16. I contacted support and was told that this is a known issue and that it was just reported today. Posting this here as I could not find any related threads earlier before I contacted support. I tried cycling power at the breaker but otherwise the switch installed perfectly and is working with manual toggling. (Cannot toggle in app yet as I can’t get past the firmware update routine)

1 Like

I am having the same issue all day today. I have installed several Wyze Switches and Color Bulbs. None of them will complete a firmware update. I am currently chatting with support to see what they tell me.

Well, they seem to think it’s the device I’m using to do the update (My iPhone 13), though I told them I’ve also tried from my iPad and it still fails. They are passing it along to the engineers.

Funny…since I got done chatting with them, mysteriously all of my devices updated. I’m guessing that someone restarted a process on their servers.


Thanks for posting. Just checked mine and had the same experience. Switch is up to date. :man_shrugging:t2:

1 Like