Wyze Switch - Dbl-Triple Tap functions work ... and then they don't?

Has anyone had any issues on the Wyze Switch of the Double/Triple tap functions working… and then NOT working.

Also, I add things to the Double-tap routine (for example)… and then go back into the routine and what I added isn’t there… it’s almost like it’s limited to a string of (x) many commands. But it’s not saving my changes in the routine either???

The single-press (non-smart bulb), works fine. The double & triple tap work fine like… once or twice… then, when I press them, nothing happens. I’m telling it to turn on 2 bulbs and 1 light strip and make them purple when pressing 2x for example.

I’m very confused. All 3 switches are doing it. I’ve even deleted/re-added them… cleared cache… forced close the application… all the basics…

I have Android 12 on a Pixel 3XL.

Wyze Switch version 1.2.20
Wyze App Version 2.27.14

Any advice would be appreciated. I will open a support ticket next if I can’t figure it out.


And to add insult to injury… now all my rules have disappeared. Ouch. I’m wondering if something is happening on the back-end at the same time of me trying to set these things up???


I think I found a bug. This is how I can break the Wyze Switch 2x, 3x, & Long Press.

  1. Create the routines for Dbl / Triple tap.
  2. Go rename all 3 of them.
  3. The routines no longer work.

To fix…

  1. Remove all your actions in the 2x / 3x / Long press area and make it say “Setup” to bring it back to default.
  2. Back out and make sure to sync.
  3. Add your actions to all the 2x, 3x, Long press areas. Don’t rename any of them.
  4. You should be able to add/remove things to those as you fine tune it and have no issues.

I did this like 8000 times tonight. I’m going insane while dealing with this bug. I love the switches now… but this bug almost broke me.


There seems to be an issue with stacking up Brightness & Color Temperature with different bulb groups. I can’t seem to add Living Room 100%/Daylight & Bedroom 75%/Daylight to the same 2x press (for example).

It will let me add as many “Turn On” or “Turn Off” as I want. I can even include telling the vacuum to stop cleaning and to go home. I have 1 chain of events that turn off or change 15 things… but I can’t make it change the brightness or temperature across 4 rooms… Seems like I can only do it to 1 room in a routine. The Light Strip groups may be an exception to this.

It’s late, I’m tired.

1 Like

i have also seen issues with using the double/triple and press and hold. Here is my issue:

i am using a wyze switch with Two (2) wyze color bulbs in my bathroom. The switch controls the load fine (on/off) what i would like to do is, at night i would like to double tap the switch to TURN the Lights ON and set them to 20% so they do not blind me in middle of night.

When i create the double tap scene, i add the command “Turn Lights ON” and Set Brightness to 20%.

When i execute it, it does not work if the lights are off in the bathroom. If the lights are ON in the bathroom the scene works fine.

My guess is that the “Macros” created need some delay time between the commands. I dont think the light has enough time to see the ON command and the brightness command that quickly.

Trying removing the turn on action and just set the brightness first thing.

1 Like

Well, it is confirmed…

I have to setup all the settings on the Wyze Switches (correctly) and then never touch them again.

IF I edited the routines for Double-press or Triple-Press… it breaks ALL the routines on that switch.

I have to erase everything and do it again correctly the first time.

Also, you CAN NOT set the brightness/temperature of 2 Color Bulb groups within the Double-Press routine. I can set a Color Bulb Group, a Light Strip Group, and a White Bulb Group all on Double-Press of the switch… but I cannot change 2 color bulb groups… when adding the changes to the script… it actually drops the rules I’ve added.

I don’t know if anyone has tried to add or delete from their existing Switch Double/Triple press routines…It is my summation that there is a bug and editing breaks the routines. All 3 of my switches are subject to this bug.

I hope I’m not just typing into the void. I probably need to submit this to support.


This is good work, Earl. :slight_smile:

Additional Bug…

The switches don’t recover from network (WiFi) signal loss. Once your WiFi is restored, you have to flip the breaker (at least I do) on your electrical box to make them boot up from scratch. Then they are fine.

I often have to do this with the thermostat. It will show a No-Wifi signal after my router has gone down and come back up. I simply pull the T-Stat off the wall and put it back on. It goes away.

1 Like

Please submit a log with those descriptions when they happen. The switch at least is new, and they need to know the problems it is encountering. Personally my switch does recover from a loss of WiFi, so I can’t participate there. But logs may help them accomodate other setups.

Whether anyone did that for the thermostat I don’t know, but can’t hurt to send those too! :slight_smile:

1 Like

In a just world there would be three Wyze T-Shirts winging their way to you, one in each size so they don’t have to ask… :wink:

@Newshound - You should try to make your WiFi unavailable for a given time (5-10 minutes?) then turn it back on and see if they recover. That is my scenario.

I haven’t tried a simple reboot of my router yet.

I need to do a helpdesk ticket and submit logs but no one else is confirming my crazy so I don’t know if it’s an issue really.

Did you ever submit this to support?

I have the same issue with creating routines on switches. I use routines to control my lamp sockets. If I use one routine (double tap) to turn the lamp socket on and save it, then create another routine (press and hold) to turn off the lamp socket), everything works fine. But if I edit the name of one routine, neither routine will work thereafter. I have tried this with multiple switches as well as with a combination of lamp sockets, plugs, and bulbs and have experienced the same loss of functionality.

No, it seems that Wyze support is not really interested in logs right now. Other than yourself, no one else has reported the issue with the switch routines. I have to believe there are more of us.

I’m trying to get them to work on the Doorbell Pro issues I’ve found and they have shooed me away.

I’m sure there are plenty of users who have encountered this bug but are not posting.

Alternatively, perhaps few people are using more more than 2 routines, and for those who do, they either name their routines at the outset, or don’t name them at all. Wyze probably categorizes this as a P3 bug at best (incidental functionality, workaround available).

With all the new products finally reaching customers, I’ll bet Wyze support is under an avalanche of issues.


Thank you! I just installed and tried to set this up tonight and was going crazy. These problems are still not fixed, and good to know it isn’t just me. I’ll see if I can get something somewhat working with my Switches and Color Bulbs.

I’ve had some success with this work around. It’s not extensively tested, so take it for what it’s worth.

I’ve not had some of the issues reported here, but I only have three switches. My frustration is not being able to long press to turn off multiple switches/plugs INCLUDING the switch I’m pressing.

So for now, I have a plug that I call “downstairs hub.” The plug is in an outlet, but nothing is plugged in to the smart plug. When I long press a switch, it turns off the “downstairs hub.” When I double click, it turns on the “downstairs hub.”

I have rules set as triggers to turn on/off what I want in relation to the “downstairs hub.” Now when I long press my Master bedroom switch, it turns off my living room switch, living room lamp, AND MY MASTER BEDROOM SWITCH.

Perhaps editing these triggers will be more successful than editing the rules in the switch itself. Worth a shot.

1 Like

I also had the double and triple press stop working on my switches. I tried the trick above, and started the macros from scratch. Bingo. All back to normal. Thanks, and great job!

No luck with this workaround. I have two color bulbs and one wyze switch. I can only have a max of 3 actions if trying to set brightness or color. Which is useless because I have two bulbs, so I need four actions. If adding on/off action, lets me add more.

Thanks @Earl.Automation I’ve reset my switches so many times and this keeps happening, removing the names now and seeing if they last longer than a day!!!