Wyze Robot Vacuum - The upcoming Multi-floor Mapping update is even better!

Read my previous posts on how to do it.

Thanks so much phillbran - I didn’t do those steps before but am now doing them and am currently installing some sort of update to the Wyze. I’m assuming that this will grant me permissions to use the multilevel mapping. If not, I’ll be back to discuss.

Thanks so much for the quick reply!

Could you provide update by when multiple floor will be released? I don’t see any dates just saying its coming.
Also, how can I sign up for BETA platform to test the multiple floor feature?

1 Like

When will this multi floor app be available?

1 Like

How do I get the beta multiple floor app?

I filled out the survey about a month back for beta, still waiting…
May I request @WyzeTeam to please provide me access? Thx

My floors are covered in black marks from the rubber tires. Guess I’m not the only one huh?

Any news? Come one Wyze, we need some info what’s happening with this feature?

1 Like

I enabled beta option on Wyze App (IoS) and added my Wyze Vacumm, then the app offered to upgrade my vaccum to 1.6.173 (from 1.6.113), The app on my cellphone says updating but it’s been on that status for more than 1 hour and nothing no change…looking at my wyze vacuum I have the 2 lights pulsing white (meaning is updating or restarting)…

Why is it “not” upgrading… I tried last night and again this morning. Same status.

Tried the steps on " My Wyze Robot Firmware Won’t Update. – Wyze" but didn’t work. Held the Home button for 5 secs nothing was played (tried twice). Finally power off the vacuum and back on and voila it played Update succeeded, headed over to device info and it is now running 1.6.173 and the multilayer icon shows up on the map (haven’t tested the multi layer yet).

Will this feature be available for Android soon?

1 Like

I registered for the beta program and have testflight set up on iphone but my firmware still only shows 1.6.113 with no update available. Any ideas on how to get the proper firmware for multi floor mapping?

Unfortunately this was 9 months ago. Hopefully it will come out soon.

1 Like

Firmware is now showing 1.6.202. Still unable to remove the charging station from the 2nd map. Cleaned both mapped floor plans well. Looked for charging station after cleaning 2nd floor plan. I had put charging station back on 1st floor plan. I moved vacuum to 1st floor after it cleaned 2nd floor, changed map in app to 1st floor, pushed charge. Flawless return to charging station. :+1: Not perfect but recognizes each floor well.

hey, I was trying to try out the multi-floor mapping feature on the iOS beta app. I am not sure what I am doing wrong but I can’t see the option to add another floor, my firmware is 1.6.113 and I can’t seem to update it. Any help would be appreciated.

Did you enable the robot vacuum under About > Beta?

Hey. I am very technically illiterate but will explain in my words. Hopefully it helps.
When you bring up the floor plan for your vacuum, on the right side there is an icon that to me looks like a triple decker graduation cap… I think it represents floor levels.
Clicking on that should bring up a choice to add a floor.
Then move the charging station to the level to map. Set vacuum to mapping.
Good luck

I have enabled my Wyze Robot vacuum to be a beta tester in the About > Beta and still don’t see a firmware update or the option to try multi-floor mapping.

Any ideas?

Also, when is the feature being released to the general public? Seems like it should be really close??