Wyze robot vacuum room edit missing

I was replying to this issue…

Until they fix the docking issue, here are some tips:

I was thinking about this and if your docking station moves easily then you could put a command strips between it and the wall to stick it to the baseboard.

Another idea, could use velcro to hold it to the baseboard so it can be removed.

Last idea is a thin sheet of plywood or plastic 16x16" that you could hot glue the base plywood or plastic so the vacuum pulls up on the sheet and docks…

1 Like

Agree! It auto-defines rooms and somehow found 4 rooms for my house but blended 2 rooms that I would want to separate. You can add blocks (don’t sweep areas) but not edit the room. I hope a map editing feature is coming.

It would also be nice to have multiple maps. My house has 3 levels and I want to be able relocate the robot without resetting the map everytime.

So is there an option to update the names of the rooms and split or merge the default rooms? In my case, its showing room1,2, etc. For my living and dining and breakfast nook, it shows a single huge room. I need to divide it into separate rooms.
I fo not see any option in the app to change it. Pls help.

Yes. Make sure you have the current beta app (2.17.6 Android) and the current beta firmware (1.6.97) and it’s in the settings menu of the vacuum.

Using the Android beta app V2.17.6, I always get an error when trying to split a room. “Operation failed. Please check your connection try again.” The vac is connected per the rest of the app, so I don’t know why this is happening. No response to in-app feedback from Wyze so far. Any thoughts?

1 Like

Cool. Thanks! I am able to edit the room names and split/merge them.
Is there a way to add vacuum to Google home? So I can just ask Google to start cleaning a specific room or 2?

Where/how do you download the beta version?


This page has the info you need: :smiley:


Namaste :slight_smile:

On Google play store, search for wyze app and on the app page, you will see a link to become beta tester. Once yoj have accepted that, you will see beta versions available for tha app that you can install!

Is there a way to add rooms manually? When i 1st started it, one of the room, being too messy, I kept closed. Then later, it cleaned that room a couple of times, but just not recognizing it as a separate room. I don’t know how I can add that as a separate room in the map?

I have the exact same issue. No matter where I try to split a room, I always get the same error message.

2Wheek,heres what Wyze support said (finally). It worked!

"First, please ensure that your Wyze app is updated to its latest version. We’d also like you to try to log out to your Wyze App, force close the app, restart your mobile device and re-log in to your app. Please reset up your Map as well. It needs to start from the charging station and end at the charging station. Any interruptions between these two can prevent the map from being saved even if there is a map showing up on the app.

We recommend going ahead and mapping the home again. Please also make sure there are no obstacles in the way of rooms you would like to be mapped and that the vacuum has a full charge.

To reset your vacuum’s map:1. In the Wyze app, tap on your Wyze Robot Vacuum.

  1. Tap the Settings gear on the top right.
  2. Tap Reset Map, then Reset Map in the pop up.

Once complete, start a “Clean” with the vacuum starting at the charging station and returning to the charging station with no interruptions during the clean."

Hope this helps.

Thanks. I’ve force closed, rebooted, etc., but will try again. It started and ended at the dock, but it took a total of three “runs” with charging between to map my house. I really hope I don’t have to map again; with kids it’s really difficult.

I had the same issue. But they’ve added a “Quick Map” feature. It mapped my 1,400 square feet in about 25 minutes.

1 Like

I just used quick map for the first time. It did a good job and finished quickly. However, now I’m trying to put in some virtual walls but I am not able to zoom the map to a high enough magnification anymore to get the walls properly placed. I’m using the latest Android beta level app.

I agree about the zooming, @bob.cronin. And I wish I could make the virtual walls “skinnier”,. It looks like the minimum is about 2 feet.

Is quick map only available on beta at the moment?


1 Like

Thank you @stchambers! I saw the quick map, but Wyze worded it as, “tap Quick Mapping below” and I didn’t see a button for it, and the first few times I must not have been tapping right on the words “Quick mapping.” I reset the map, did a quick map that was less than 15 minutes, then I was able to split rooms successfully. And I agree as well about the level of zoom, @bob.cronin - it was difficult to place some of the splits where I wanted.

Thanks y’all - much better than waiting for Wyze support!

@2WheelPig, you’re not alone. I was also looking for a Quick Mapping button below the text. Hopefully they’ll change that to “Tap here for Quick Mapping”, or actually adding a button.