Wyze plugs suddenly disconnected - won't reconnect at all

I have two Wyze plugs that were working just fine (amongst the 15 plugs I have), and without any rhyme or reason, they stopped working. Just a blinking blue light.

I attempted to reset, and re-add both plugs, using a Pixel 7 Pro, a Pixel 6a an iPhone 10, and an iPad, and set up fails on all devices. I used every device at my disposal, to rule out anything specific to one device.

Granted, the plugs are not that expensive, but it is concerning how a device can be bricked without explanation. Any ideas on how to breathe life back into these plugs?

What model of plug do you have?

Pre 2021: no black CFH Key Logo on the back
2021: CFH Key Logo or “2021” mark
2022: CFH Key Logo or “2022” mark

Press and hold the setup button until it cycles for a factory reset.

If it is a pre 2021, shut off your mobile data and make sure BT, WiFi, and GPS are enabled.

Hi @SlabSlayer

I confirmed, they are pre-2021 plugs.
I’ve disabled mobile data on the Pixel 7 Pro,
I have no mobile data on the Pixel 6a. WiFi and GPS are enabled on both Pixels.
I’ve also tried an iPhone and an iPad that have no mobile data, with only WiFi and GPS.
It just hangs on “Connecting” until it fails, on all units.
Each device is currently on a different version of the Wyze app, which helps dismiss it’s something to do with a particular release build…

Time to order some new plugs - these have apparently reached EOL. :frowning:

They have not reached EOL. They are still supported.

The pre-2021 plugs are notorious for dropping offline unexpectedly and also for being very finneky to install.

The reason they are a pain to set up is more a function of the new phone technology. The newer phones do not like a WiFi connection that doesn’t have internet. As soon as the phone senses there is no internet, it will immediately revert to the next available network with internet. That is why I had you turn the mobile data off. But, it may also be reverting back to your WiFi too soon.

The pre-2021 plug produces its own WiFi connection to the phone to setup. So, the phone does not like to hang onto the connection there since it doesn’t have internet.

You may want to try using Airplane Mode. That may have additional settings that keep the WiFi where it should be.

Here is a great read for the setup of these plugs by @Newshound:


THANK YOU @SlabSlayer !!
It WAS switching back to my home WiFi, so I followed the instructions you provided. Tapping “yes” to remain connected did the trick!

Much appreciated!



You are quite welcome! Glad you found a solution.

That is why Wyze moved to BLE setup on the plugs. The new phone operating systems were far to immediately controlling of that WiFi connection and causing too many install failures before it had a chance to do what it needed to do.

1 Like

I tried airplane mode on my iPhone 14 Pro Max and it still refuses to move past “connect to your phone.” I verified that the phone is still connected to the pre-21 wyze plug. I tried a second pre-21 plug and same result. I’m just going to chunk them in the trash. I was a very early supporter of wyze, kickstarter early. I gotta say that I’ve been very unhappy about the long term reliability of many of the products. And I own nearly every product…well over a dozen cameras, not including ones I gifted. The spotlight cam is so unreliable I never installed the other two i purchased.