WYZE Plug - No Joy

OK, have two WYZE plugs at home. Each powers a 3D printer, monitored by WYZE Pan Cam so that if a spaghetti monster develops when I am on the road, I can cut power. Decided to take one printer and one plug to my work location (different wi-fi) and a WYZE Cam (non-pan) for the same purpose. Camera connects to the new wi-fi but plug will not. It must be a 2.4ghz signal or else the camera would not connect, right? I can also see the plug’s wi-fi signal, so apparently it has connected to the new work wi-fi as well, right? The plug’s wi-fi appears with “4-bars” so it would seem to be happy , but phone (Samsung) will not connect. Sometimes get the message “Ready to connect when network signal improves.” Phone sees and monitors/controls the camera fine, although it (the camera) frequently goes off-line and will only come back following an on-site power cycle (which kinda defeats the purpose of having it.) Are these two issues related? Even if I can get the plug to connect, is it going to randomly drop the connection and turn off while the printer may be fine? If it’s not reliable in that respect, I might as well not use it and risk the spaghetti monster. Suggestions?

turn off your mobile data when setting up that plug that is having trouble connecting. see if that helps the connection and the setup. sometimes when the phone goes to transfer the wifi data to the plug so it will connect, it gets confused with the mobile data somehow and mushes up the process. we have found when that happens turning off mobile data and going through the setup process again allows the wifi info to go from the phone to the plug seamlessly. based on your description this is what it SOUNDS like is happening. give that a shot and keep us updated.


Ok, so that worked. If this is a known “bug”, can it not be eliminated with a version patch/upgrade?

1 Like

Some phones don’t like connecting to a WiFi network that doesn’t have an actual Internet connection, which is what the lonely Plug looks like to them. So they switch back to mobile data, which doesn’t have the Plug on it yet. So unless you turn mobile data off, you can’t prevent this and initialize the Plug.

We actually created a thread about this in the old days:


I’m glad you were able to get it working.

I actually had a bit of a “moment” a month or so ago when I got a new plug, I forgot about this little trick and it took me almost 4 hours of trouble shooting my router before something snapped in my head and I remembered it. I felt just a wee bit silly.