Wyze Plug Firmware Version Released Today - 3/4/20

Hello, forum folks!

We’re sending out an update for Wyze Plug today ( This provides more accurate troubleshooting data in the logs and has bug fixes.

If you would like to read our release notes, you can find them here:


“Release Notes & Firmware” lists the new FW for the Plug and also only one prior FW

Issue 1: Before I update a Plug to I want to preserve a path to restore the prior version if there are problems with the new version, much like reverting to a former FW for Cameras. But, “Release Notes & Firmware” does not have provision for me to download In fact, there are no links to download any of the Plug FW versions. Can links for downloading be made available?

Issue 2: If I were able to download a particular older version of FW for a Plug, how would I install that older FW?

Issue 3: Some of my Plugs have FW while others have but is not listed as a FW version for the Plugs. Was this an oversight or was a Beta version?

The .56 may have been the original version. We only post the updated versions on the Release Notes page.

I don’t believe you can manually flash the plug firmware and that’s why those files haven’t been added to the page.

1 Like

Thank you for the quick response. I have 10 plugs that are used heavily so I’ll update a couple at a time to be sure there are no serious problems. But, without the ability to revert to a prior FW version, it is not clear what could be done to recover from problems that might be presented by new FW.

Also, it would be helpful if we had more specifics about what is meant by “bug fixes” in the release notes.


I’ll share your feedback with the team. :slight_smile:

With vague labels like that, it usually means that they were back-end or tiny fixes that weren’t widely experienced. We often call out larger bug fixes separately.

1 Like

I have two plugs. One updated to the new version and I can’t get the second to update…it always says upgrade failed. Is there any way to flash the plug? I’ve tried multiple times to set it up again and delete it.

Hello @sdoxsee and welcome to the community.

As far as I know there is no manual way to flash the firmware of the plug, however there have been times were I got an update failed message but the firmware was actually updated.

1 Like

Thanks @WyzeJasonJ. Mine continues to say it’s on the old version and prompts me to update every time I look at its settings. I just got the device…but this isn’t looking good :expressionless: Thanks

I would fill out a support ticket if you haven’t already.

1 Like

@WyzeJasonJ thanks for the suggestion! Cheers.

1 Like

Thanks, Jason21271!

@sdoxsee, I hope they get that sorted out for you soon. My first suggestion would be moving the plug closer to your router for the upgrade if you haven’t tried that yet.

1 Like