Wyze OG cams killing SD cards

So far since I bought my OG cameras I have had them kill FOUR SD cards. What’s going on with this? Am I the only one having this issue? I think it’s been in different cameras each time although I have not been tracking that, though I should’ve been. Is there someway to resurrect these cards? I’ve tried formatting in a card reader and that has not worked. I love the cameras, but this can’t continue. When I’m gone, I won’t be able to put new SD cards in, and I don’t really feel like buying new SD cards every month anyway.

I don’t remember anyone posting this issue, and I can tell you that I have not seen this problem with my four OG-Tele cameras.
Are you using high endurance uSD cards? And are you recording continuously or events only?

Where did you get the cards? Brand? Capacity? Rating?

Continuous recording. I usually use SanDisk 32gb SD cards. I haven’t pulled the latest two dead ones out of the cameras yet, so I shouldn’t assume that they’re not recoverable, But the first two weren’t so I don’t have high hopes for these two. i’ve never heard of a uSD card, so I guess they probably are not that. Just regular old SanDisk camera cards. The same thing I have been using in Wyze cams without issues since I got my first ones in 2018.