Wyze Lock Gateway won't connect to WiFi after reset

I bought my lock a week ago and was able to set it up just fine. It’s been working for almost a week now.

This afternoon, when I went home, I noticed that the gateway’s green light is blinking. I checked the app and my lock and gateway are both offline.

I tried to troubleshoot and did all the steps available in the troubleshooting guide, but it still won’t work.

I deleted the device from my Wyze app and tried adding it back. I get to the part where I choose my lock gateway, then choose the wifi network and type in my password. After I try to connect, it quickly fails to connect to my wifi network. My wifi is working fine, signal is very strong, and my gateway is very near to both the lock and my router. All other devices can connect to my network just fine.

I try to reconnect at least 20 time as of this writing, but same issue, it won’t connect to my wifi. I tried a different SSID and a different router, same issue.

I did notice one thing. When selecting my Lock Gateway from the list during the pairing process, the serial number of my Lock Gateway is different:
It’s not the same as the one on the actual device.

Is there a way to reset the device? How can I fix this?

1 Like

I would definitely get in touch with support about this, chance you may have a faulty gateway.

WYZE Support

Live support is available:


Monday - Friday 5 am - 6 pm PT

Saturday 8 am - 4 pm PT


I am having the exact same issue!. The SN is also a bunch of 0’s. I have tried everything. Did you get this resolved? I haven’t had time to call in yet.

Same here! My gateway has been working for the longest time. It is now offline and I can’t get it back online. Fails at connecting to WiFi. Log sent.

Mine quit working yesterday, I deleted the device and trying to re-install but it will not connect.

Same issue - Wyze lock and hub worked great for over two weeks. Today, I see the hub if offline in the iOS app, the light is blinking a rapid green on the hub itself, and I tried every step for the lock troublehshooting. Cannot get the hub back on WiFi, even through the app can see it when I re-pair with (with the correct serial number, not all 0s). Quality control seems to be a dumpster fire at Wyze right now as the outage a week ago for the cameras was a disaster. Love the products but this stuff seems to be beta. Who are they hiring? Incredibly frustrating.

This is an Amazon issue. The AWS is messed up and it’s causing all sorts of issues.

Of course. AWS can break just about everything everybody uses when it doesn’t function properly. SMH

This appears to be a regular occurrence. I got home today to notice my gateway was blinking red and the app showed it was offline. After an hour and more of trying to edit the wifi network information, then deleting the device and trying to add it back after signing out app, re-starting phone, re-positioning lock in another outlet, changing batteries I jump on with Support and they just say that it is a known issue. I now decided to take a look here for any report or to see if anybody else is experiencing this as its been a couple hours and my last attempt (5 min ago) still did was not successful, it fails on connecting to my wifi network, Now I see from this feed that it may be AWS issue. I complained a couple hours ago to support about lack of notification and thought at least there would be something here regarding the issue but nothing, no official acknowledgement of an issue exists.

The only official acknowledgement I am aware of on this issue is on the service status page found here

Here as well scrolling along the top of the page https://wyzelabs.zendesk.com/hc/en-us

OK, cool, clicked around the site and never saw that…Thanks

Yup saw that, but before this thread I had no idea the issue was caused by AWS and from that message it states that AWS is responsible for decreased ph support nothing about affecting my device. But thanks

You’ think since they have the ability to blast mail our accounts when new products are released that they could do the same with some sort of notification rather than a snippet buried in the site

1 Like


as I read this, I don’t see or hear any resolve. I’m still offline I guess from middle of last night? The gateway says its connected but flashing red but before I mucked with it, it was flashing green. Either case I was unable to connect regardless what i did. It UNLOCKED MY DOOR AND LEFT IT UNLOCKED ALL NIGHT MAY BE? I have no idea just found it unlocked this morning… THAT REALLY SUCKS.

[UPDATE] asof 1:30am PST, I was able to connect also confirmed that AWS is in better health:

Amazon Elastic Container Service (N. Virginia) [RESOLVED] Increased API Error Rates and Launches
Amazon Kinesis Data Streams (N. Virginia) [RESOLVED] Increased API Error Rates
Amazon WorkSpaces (N. Virginia) [RESOLVED] Increased provisioning error rates

It sure would have been nice of Wyze to notify us that their system was down.

+1 for another user experiencing issues as well. I’ve unplugged, reset, uninstalled app, etc and still lock & gateway shows offline. So at the moment its back to a non-smart old fashioned lock which at the very least works. I’m guessing as previous replies have mentioned the issue being AWS. From what I’ve heard/read on the news, AWS seems to be back up for most sites/companies that were affected but agree Wyze has made no formal announcement on the lock issue. :frowning:

Hi, I am having the same issue for about a month. I have tried every now and then to get it to connect over the past month. It worked fine for a month or so when I first got it. It gets to the point where it says it is connecting to Wi-Fi and it may take a few minutes and then it gives an error message that it cannot connect. I have followed all the tips and since I didn’t have any problems the first time I connected I’m not sure what is causing the problem now.

Believe me I feel your pain. If you have tried all the tips and have no relief I can only think for you to try the following, apologies if I repeat tips already here it has been a few weeks since I looked at this thread and I did not re-read it. check for and delete the gateway device from the WYZE app. From here you can take the steps as if you were installing it for the first time. If that still does not work, delete the gateway and log out of the WYZE app and delete the app. Check any other phone or tablet that you own. You might have downloaded the app there and forgot as it may not be used often. Check to see that the gateway device has already been removed in those instances of the WYZ app. Sign out and uninstall the WYZE app completely everywhere else. UNplug the gateway device. Restart your phone or device you will use as the primary for installation. Download, install and log in to the WYZE app. Reset the gateway lock, I THINK this involves un-plugging it and then plugging it back in with the button depressed and holding until it blinks between red and blue. (Please research to confirm this before you perform, I will not be responsible for any outcome known or unknown). Now run through the set up process as when you initially set up the lock. You can read through the following even though you might have seen before and take note of the recommendations:

For me I was able to get the lock working after I saw WYZE notification, buried in some page of theirs, that AWS was back up on the following day.

Just had the same thing happening to one of my gateways. Showed off line so I power cycle, no go. Attempted to pair and not found, deleted the device and now seen in pairing but serial number in app is all zeros. Give it the WiFi password and it instantly fails. Repeat endless times and reboot ally APs and router. While that’s still coming up (e.g. WiFi connection viable but wan/internet down) it didn’t instantly fail after password entry, so I think this has to be server side. After the reboot and Internet back, it goes back to instant fail

Wyze support chat led nowhere so hope this self-resolves once the server glitch is fixed.

I too am having the same issue. Serial is all zeros, and the green light flashes 1 long, then 6 short, then 4 short. That has to be an error code. When I can finally get it into pairing mode, i get all the way up to the wifi password entered, and then it fails.

I purchased mine in Nov 2020, so its easily out of warranty, chat support was useless, and i cannot find anywhere to buy just the gateway.

Has anyone made any headway with this?