Wyze lock Alexa’s integration not working properly...yet again!

When asking Alexa to lock and unlock, the lock responds and does the proper action however Alexa keeps saying “lock is not responding”

1 Like

Having the same issue.

And as of 2 days ago, unlock is completely dead via Alexa.

Alexs app is up to date

Devices - Includes echo show, several echo dot, echo plus, echo gen 4, and wyze lock and gateway

Wyze gateway Model WLGW1 Firmware Wyze lock Model WLCK1 Firmware
Wyze App 2.19.15

Problem - Alexa (skill and app) recently (past two weeks or so) Stopped what appears to be recieving or processing a response back from wyze lock. After 60 seconds of either unlocking, or locking the wyze lock Alexa responds with front door is not responding.

This happens while locking or unlocking the lock and is 60 seconds for each then responds back the lock is not responding.

Performing a LOCK operation through alexa on a LOCKED door, response comes back normal.

Performing a UNLOCK operation on a UNLOCKED door response comes back as normal.

Wyze lock and gateway firmware are both up to date as well as the wyze app. The wyze app processes without issue with bluetooth or wifi

Alexa will do both unlock and lock the door but it is the final response that the door is locked or the door is unlocked where it is failing. As I said it seems Alexa does not recieve or does not process the status of the lock after performing the operation. This to me is miscommunication between the wyze skill of the lock status and the alexa side of the skill.

I have removed and re added the lock completely, several times from both Alexa and wyze app

I have moved gateway for lock right next to lock (although that connectivity is not a problem)

I have tried to change networks for the lock

I have tried changing router for the lock

I have factory reset the lock

I have removed link and re established link between wyze and alexa skill

I have removed and rediscovered lock within Alexa several times

I have removed and left out for a minute then re installed batteries in lock (they are at 68% but tried it anyway)

Other forum folks in wyze forum are having same issue but we have been unable to figure it out.

This worked for about a year with no issues until recently. I have also opened a case with development team over on the Amazon side. Phone calls to wyze are always call back during business hours (I Work Wyze, need better support hours IMO)

I asked about access to the backend devices for alexa like they have for smartthings but was told they dont have that, I hardly believe that is the case

I would also like to find out if we have backend access to wyze devices and the device fields such as status, firmware, last update etc, do we have that does anyone know?

@wyzesupport if they exist

I would also point out this is still …

sold on Amazon as WORKS WITH ALEXA
Control this with your device: Echo Show


I did some troubleshooting today and I agree to what Larry.knights.lk stated above. I removed and re-added both the gateway and lock, disabled and re-enabled the Wyze skill on the Amazon app and still no fix. Alexa will lock and unlock but just like Larry said, the confirmation is always “lock is not responding.”

Wyze support said talk to Amazon, nothing more from Wyze then that. Have had a case open with Amazon development but nothing there either. Anyone hear of anything being looked at on either side?

Wyze support said they would follow up via e-mail, but nothing yet from them. Still having the issue…

I doubt that the new firmware that was released today fixed this issue. Anyone found a solution and/or had any luck with support? After the update, I disabled the Wyze Alexa skill and re-enabled with no luck… I am still getting the “sorry, the lock is not responding.”

I also have been having this problem. I also had routines triggered from the lock and also Wyze door sensors none of these routines trigger. it appears that amazon is sending signal to the devices but not receiving

1 Like

Wow!!! I just ordered a lock. Is this issue still out there?
Also, if you link Alexa, can anyone just come to your door and ask Alexa to unlock it?

The Alexa lock/unlock integration started working properly again within the last 2 weeks, at least for me. But it was definitely broken for a while.

As for unlocking via Alexa, you have to allow unlock by app and unlock by voice in the device settings and then set up a voice pin. You have to say the pin everytime before Alexa unlocks the door.


Thanks. Good to know there is a pin. I just got my lock and plan to set it up today.

Having this issue yet again…

Alexa will unlock/lock but will always say “sorry lock isn’t responding”

Same here as well, also having a much delayed response to routines with sensors as well. No other service is having this issue, just seems to be something with Wyze to Alexa. I can see the activities happening all just fine, it’s the routine side that is delayed. Lock response as you said, but gives the response back error.

Interesting. I just tried mine and it’s working fine. I’ve seen this with various brands of products in the past. I usually just unlink and relink them.

RE-upping an old thread, but I read it through and didn’t see if there was a resolution. I just installed a WYZE lock a couple weeks ago, and I am having this same issue. WYZE lock responds to Alexa request fine, but then says “Sorry, not responding”. At this point, I am not sure I can trust it if I am not within earshot/eyesight of the front door to confirm it is locked. Can anyone update me on whether there is a fix for this? Should I switch to Nest? Everything is currently up to date.