Wyze Connecting/Authenticating and Taking Too Long to Work After Plugging It In?

I bought a wyze camera through amazon and just got it… At first when i set it up, it was great for the first few hours… I also have an old 32gb micro sd card that i tried to put it in and it did not fit. Does that mean its not compatible? You can’t fit it in.

The other thing is this. When i first used it for few hours… no microsd card, it seem to be good. But later on in the day, lot of issues. First off, when i unplugged the power cable from the camera, i then plugged it back in. Is it suppose to make a clicking sound and have an orange light blinking for over a minute? The other issue is this. After that, the light turns blue but blinks between blue and orange for at least 30 seconds minimum. Its like 1 minute almost it seems. After this, sometimes it would stay blue the light in the back and camera works. But when i view my camera on the wyze app on my iphone, every single time when im on home and click on wyzecam,

It shows

Connecting Camera (1/3)
Authenticating (2/3)

Then it works. But there is always a few second lag with each of these words. Is this normal? When i first started using the camera, i don’t think it did this? So it always has to show the word connecting camera and authenticating before you see the live stream? Im positive it was not like this when i used it for the first hour?

The other thing is this. Many times it doesn’t even connect and either says error 27 or there is some other issue where it shows connecting 1/3 and does not even connect. Or authenticating 2/3 and doesn’t connect. I then wait a long time and either it works later on, or i click reset device in one of the options. But many times you can’t even reset it.

Do i have a defective unit? It worked great at the beginning. Also does that mean my old micro sd card is not compatible with it? I saw the wyzecam video where if you put microsd card in and it regconizes it, it should make this sound. All it did is making a clicking sound. This is the old micro sd card i have. . Does this even work?


What can i do now? Can i do a factory wipe and start it brand new and maybe that would work? Also is it normal for it to take over 2 minjutes everytime for it to start working when you plug it in again?

Considering how many different questions you have, I highly recommend you go to the Support section of the Wyze website, and review the support documentation. The search function is very handy for finding specific information, and many of your questions will most likely be answered there. If you still have some questions, please come back and let us know.


Keep in mind that this forum is primarily a user to user community. If you don’t get a helpful reply here, I suggest you file a support request including the log files for more help. You might want to go ahead and submit your ticket now as there is somewhat of a backlog. If you end up getting the issue resolved before support contacts you, then you can always let them know that it’s already resolved.


Hi thanks. But all that is the documentation only right?

Because i want feedback from other wyze users if they have this issue or not. At first when i got it and used it for few hours, i liked it. Then all sort of issues afterwards.

1 Like

to see what issues other users are having just use the search button and keywords. more than likely you’ll find something similar along with a host of answers to the stated problem. keywords for you might be

error 27
doesn’t connect

as for your sd card. I would recommend a new card, class 10 and look into getting “endurance” classified cards made for constant read/writing.

Hello Pauly2 and welcome to the Wyze community.

If you are still unsure about which SD card to choose if buying a replacement this article has some good end user information: What SD cards are you using? have you had any issues?

1 Like

Thanks. But can someone tell me about the connecting, authenticating? Does that happen always before there is live feed? The kb/s is 0 for 1-2 seconds before it goes to like 50kb/s?

yes, that will always show the 1/3… 2/3… steps before the live feed

Bam thanks for clarifying that.

But what about when you unplug the wire from the camera and then plug it right back in? I don’t mean the thing in the outlet… just the wire that connects to the camera in the back of it. When you connect it back, is there like a clipping sound? Then does it flash an orange light for like 1.5 to 2 minutes or so? Then it goes blue and then orange for another 1 minute… before it finally turns blue light only in the back and starts working?

Or when you plug the wire right back in the camera, it immediately starts working or pretty quickly? Because everytime i do it, it seem to take at least 2 minutes minimum. It always blinks orange for like 1.5 to 2 minutes… then blinks from blue to orange for at least 1 minute and finally when its blue… it starts working. Is that how it works? Because when its blinking orange or blinking blue and orange, when i try to view the livefeed… i cannot until the light turns blue?

There is an operating system installed on the firmware of the camera. Everytime you remove power, and then restore it again, the camera has to reboot, and then reconnect to the network. This is true of all IoT devices. Please see the following article, and see the section entitled “How to setup your Wyze Cam”. An explanation of what the different color LED lights mean is there. The second link is for using an SD card with your camera.



1 Like

Hi there. So basically what i described exactly with the orange light for 1.5 to 2 minutes, then it blinks blue and orange for another 1 minute and then it goes blue afterwards and starts working, that is the correct process with this camera? Because when i first used it the first hour or so, i remember pulling the power out and putting it back in and i don’t think it did that. But of course i did that maybe 2 times.

@pauly2, please re-read my last response, and also check out the links I posted for you. I’m afraid powering on an IoT device is not like plugging in a crock pot or can opener where you can immediately start using them. You have to allow it to finish its boot cycle. The solid blue light is the final stage where it has established the network connection.

If it works fine WITHOUT the SD card then suspect the SD card.

I disagree with some of what Dread wrote, I find it very much like a crock pot. Plug it in, turn it on and it takes a while to warm up.

I had one V2 that gave the same symptoms, took several minutes to get to the solid blue light of life, whereas my other 5 cams got online in about a minute. When I went to take the SD card out it was “jammed” in there and required the small pliers on my Swiss Army knife to remove it. After carefully reinstalling, removing, reinstalling the SD card (to ensure it was not stuck again) the camera has functioned fine ever since.
And I’m often fiddling with my cams, turning them off and on for various reasons, so it has gotten powered cycled a bit.
I’ve since gone to the Wyze rebranded 32GB cards.

I can’t get the SD card to even go inside the camera. I mean from what i posted in the link, should that fit? It doesn’t fit in fully like clicked in so to speak like if i take that micro sd card and put it in android phone.

I just tested it right now with unplugging and plugging the camera in. Basically the moment i plug it into power, it takes a total of 1 minute 45 seconds for the blue light to show up and not blink anymore and start working. So is that about right in how long it takes for the camera to start working when it was powered off or cable unplugged?

The moment i plug it in, light is orange and there is a clicking sound… Then 25 seconds later another clicking sound… then it blinks between orange and blue for 20 seconds… then goes to blue for about 50 seconds. So basically it takes about 1 minute 45 seconds until light is blue and the live stream is there. Can others confirm this is around how long it takes for camera to start when powered off or cable unplugged and you hear 2 clicking sounds during this process and how the light goes? Thus orange light… then flashing between orange and blue… then blue light flashing for a while… then blue light stays blue and it starts working?

Also in addition to this. If you have no microsd card, i know when you view the livestream, there is option to take picture or record video. But you could record the video as long as you like basically? Or its only 12 seconds? So the point of the microsd card is when there is motion detection, it records continuously as oppose to 12 seconds? But if you are viewing the live stream as it happens… whether you are looking at it or got notification via motion detection, how long can you record what you see on the live stream on without microsd?

Okay so i went outside and then tried to view wyze using my data. It kept connecting 1/3 and authenticating 2/3 and it could not even connect to the camera. It connected twice in about 10 plus tries and when i viewed the livestream, when i click on it, it stops The time stays the same and freezes.

Previously i was looking at the live stream with the wifi and close to the camera and it was fine. So does anyone here have this issue? Because if i can’t view the livestream via data… then what is the point of this since i like to view it when outside? Also when i came back in house and using wifi, i notice the video is now not only black and whit, there are 4 red lights from the camera? Can someone explain this?

Okay so i think issue is i had the night vision on so to speak in the button to the right of live stream. I clicked it and color went back to color.

However, i had issues viewing it from my data. Im using 4g data so anyone here have the same issue? I mean if i cant view the livestream with my data on iphone, then its pointless right?

@pauly2 I have all the issues that you have and I put in a brand new micro sd card.In all the time it takes for live video to pull up I literally can drive all the way back home and just check on everything myself and the camera still won’t pull up live video. Sure it has nice clear video when it finally works but it is so useless right now when it takes too long to work. I’m trying to be patient and wait for an update that will fix everything but I am beginning to look for a different camera to use that is more reliable than wyze cam.

what are respective speeds ( done with an actual speed tests, not advertised speeds) for your data and wifi?

check them each time you have trouble vs times you aren’t having trouble as well.

I used to live in a bigger city and where the weather was bad, sport were on, families just getting home ( all the busy time) the bandwidth for the city would absolutely plummet and it wound like you are not getting the speeds needed to connect, which is impressive because our cameras don’t need a while lot.

1 Like