Wyze Cams No Longer Allow Firmware Updates Via MicroSD?

I get the impression that firmware updates can only be done from within the Wyze app? I tried four different 32GB cards and 3 different versions of firmware including the one rtsp demo. None work. I am using Tinycam Pro and saw some walkthrus but they made no sense because they never mentioned the rtsp firmware which is required. One of them used a protcol (Proprietary h264) which does not exist. Another suggested using “Cloud”. That was truly puzzling.

I suspect the camera will use about 500GB of bandwidth per month so the Wyze service might not work. I currently use about 700 between my two other cameras. I use One Drive.

Why did Wyze disable the MicroSD option?

Wyze hasn’t disabled sd card firmware updates. You need to follow instructions exactly for the particular camera you are trying to update. Specific file versions and naming conventions for the firmware file for every camera. RTSP versions aren’t available any longer and were only available for the V2, V3, Pan and Pan V2 (I think.) RTSP firmware isn’t required for TinyCam either.

I followed the directions to the T. I know what files versions are for what and the various protocols for updating/resetting (This is me third wyze cam. I have v1, v2 and this v3 and had no problems updating the rtsp firmware on 1 and 2. The v3 pro won’t even do stock firmware update from a couple weeks ago.

RTSP IS required for TinyCam. It’s always been that way. I don’t know what the proprietary (h264) option is but it doesn’t exist. The options I have are “Cloud”, “RTSP over UDP” and RTSP over UTC". The Tinycam apps on my tablets are all up to date. I use UDP to avoid ack fests on my network.

In my opinion, the biggest issue with uSD card flashes is a result of Windows hiding the filename extension (Windows default). This results in people putting an extra .bin on the end of the filename.

I have 15 of my Wyze cams set up in TinyCam: a mix of Cam V2, Cam V3, Pan Cam V2, and Pan Cam V3.

None have the Wyze RSTP firmware installed, and all are either on the latest firmware versions, or in some cases, one firmware version behind the latest version (depending on which camera model). I selected the “cloud” protocol for my cameras in TinyCam (but I do not have a TinyCam Cloud account). The tricky part, was picking the proper channel number for each camera. I can’t remember how I figured out what channel was used by each camera.

I also have several Wyze OG cams, but have not tried to add them to TinyCam yet.

I think that I am a bit behind on the TinyCam version - I have version 15.3.8 installed.

No. It’s not.

I run Tiny Cam Pro and have every cam streaming on pure stock firmware.

OG and Floodlight Pro Cams are not yet compatible… But all 24 of my other cams… Including V3 Pro, run on stock firmware.

I’m not spending any more time on this. It does not work for me. Nobody has a way to get connected so I have no choice but to assume that RTSP is required. I’m returning the device.

It’s actually quite simple.

  1. Add an IP Cam
  2. Each Cam gets its own Channel #
  3. Cam Brand Wyze Labs
  4. Cam Model is either Wyze Cam for non PTZ or Wyze Pan for PTZ
  5. Protocol is Cloud
  6. Put in your Wyze Account Username and Password
  7. Provide the 2FA if you have it on
  8. Once you are successfully logged in, you can select the UID (the cam you want to add) from the UID list that is populated from your Wyze Account.

RTSP is absolutely not required for TinyCam. I have all my cameras connected to it and NONE run RTSP firmware. TinyCam interacts directly with the cameras but you need to give it your Wyze credentials so it can connect to them. When you setup the cameras in the TinyCam app you need to select Wyze for the camera type. You need to know the UID for the camera (which prevents loss of connections if you add, remove or change the order of devices in the Wyze app.) Some of the newer cameras aren’t supported yet. But the the V2, V3, Pan and Pan V2 work fine, without RTSP firmware.

1 Like

Wyze cams won’t flash firmware from certain sd cards that otherwise work with the cams for eg recording.

Now that’s solved :wink:

I am using the same sd card that I used on the v3 (not pro). I have encountered problems with the workaround and I end up with hundreds of ~KB files with no video. Tried to reinstall tinycam and now it doesn’t save recordings at all. Neither the wyze app or tinycam can record locally. I am throwing in the towel and returning the device for a refund.

Tried going from beta, back to non-beta on a v3 Pro.
Gigastone 128 Gig that works fine for recording would not start a firmware update at all.
Would never even give me the purple light, just “ready to connect”.
Smaller 32 Gig SD card did give me the purple light, and started flashing red afterwards, for a long time…
It finished without letting me know anything,
Re-set up cam and the latest public firmware is there.

The 128GB card is factory formatted exFAT. Flashing requires FAT32. That’s why a 32GB card is a mandatory requirement.

Flashing back won’t give you any confirmation other than a cam reboot.