Wyze Cam v3 wont recognize a 64GB SD card

Received 2 V3 cameras today, got them connected right away without issue.

I put in 64GB memory cards in both of them and neither will recognize the cards.

I inserted a 32GB card and it worked immediately.

Both cameras have the firmware on them.

Is there a newer firmware that is supporting 64GB cards?

I did a full format from my PC and using SD Card Formatter.

I did hold the reset button for 15 seconds to to reset the camera.

Wyze only supports a maximum of 32GB cards, some people have had varying success with other sizes, but there is no firmware that increases support.


Well I have 10 v2 cameras running all with 64GB cards with no issue.

I find it hard to believe thee same isn’t true for the v3

This works

Download the freeware program AOMEI Partition Assistant

Format the microSD card for FAT32.

v3 camera now recognizes the 64gb card

I am just relaying what they support, they only support up to 32 GB in the v2’s also, people seem to have more success with them in the v2’s so far.

Thx very much for the info. fdnyfish! formatted 64 gb Micro sd card for v3 Wyze cam works 100 0/0. Note very important, format to FAT32. again thanks.

The PAN and V3 cameras use 32GB and FAT 32 Format, but many owners are using 64GB and FAT32 format and some class 10 128GB micros sd cards instead. Can Tech tell us What happens if a 64GB card is used? will it become corrupted or crash memory? That is the answer we are looking for…

All they will say is they are not supported. On my own I have found anything bigger than a 32gb will not work when flashing firmware. My assumption is they are willing to support up to 32 gb after that success starts to get hit and miss, I do not know why, but to me that would be a good reason to stop support at 32gb.

I also use only 32GB, but the KEY TO HIGHER Capacity cards is to Format them separately in a FAT32 Format. That always seems to solve the problem.

I have a bunch of V2 Cams and have no problem running 256gb micro SD cards in them that are formatted to FAT32. I like the flexibility of staying away from home for long periods and knowing the security cams are recording. I just got my three V3 Cams. I tried getting 128gb and 256gb cards working by putting them into the V3 cam as brand new exFat, reformatted FAT32, and even tried taking a working 256gb FAT32 out a V2 Cam and putting it in the new V3 Cam. No luck. That sux because…as we all know…the V3 Cam is better in every way. I have yet to try a 64gb…but glad to hear it has worked for some folks here.

Have a bunch of high endurance 64 gb SD cards. Some WOC cameras don’t recognize the card so I pop it into a cam pan and format it. Seems the pan cam doesn’t have issues with larger cards.

1 Like

Good news: I was able to get 128GB working on v3. See detailed instructions below on how to do it correctly. Have to follow the directions in the order given otherwise it will not work.
Sucky news: There is no way to get it to recognize 256GB

I tried Samsung 256gb, which work just fine in Wyze Cam v2, but the new v3 just flat would not accept it. I even formatted it FAT32 using fat32format.exe utility (https://www.softpedia.com/get/System/Hard-Disk-Utils/FAT32format.shtml) and it still would not take it.

Than I tried 128GB by SanDisk. I did the following in that order, and it worked.

(1) Formatted 128GB card with fat32format.exe utility on the computer to FAT32 format,
(2) Powered off the v3 camera from the app.
(3) Unplugged the v3 cam and counted to 15
(4) Inserted the 128GB sd card into v3
(5) Plugged the v3 cam into power source
(6) Turned the cam on from the wyze app
(7) Waited for 30 seconds, and then went to advanced and voila, I could see 128GB card recognized and enabled.


I tried this & it did not work for me. Using a SanDisk Ultra Plus v10 128GB :thinking:. You did a full format?

No, I did quick format to FAT32 (not exFAT). Did you follow my directions in exact order? Has to be done in that order, otherwise it will not work (I know I tried). Also, do not try to use cam’s “format” option, that will result in card not being able to be detected at all.

1 Like

Yes I did follow the directions as specified. I am doing a full format right now & will try again. Someone on another thread mentioned waiting a few minutes rather than 30 seconds. I think I will try that as well. Thank you for the help. I am frustrated after waiting all this time for the v3 for sure!

Are you using fat32format.exe utility?

I know. It is ridiculous that they purposely disabling support for larger sd cards. There is no technical reason for that at all. This appears to be a commercial move to push their cloud service, which I could understand if it offered 24x7 continuous recording, which it does not. In v2 there does not appear to be a hard set limit in their firmware, but it appears like they put in a rule in their firmware for v3 to explicitly stop sd cards with sizes larger than 128GB from even showing up in the app. Not cool.

I think you are right. I have cam plus on a free trial right now & I don’t like it anyway.

Yes I used the fat32 as you suggested. The full format is taking hours. Probably won’t take another crack at it until tomorrow. I need a beer!

So FYI, I ended up updating the firmware & the v3 recognized the sd card right away. Suggestion from another thread.

1 Like

Goodness, I forgot to mention that step :man_facepalming: . It prompted me in the very beginning to update the firmware, which I did before even trying the sd card. I will update the instructions.

1 Like

No worries. I actually did not follow all the steps this last time. Once the card was formatted, I inserted it & got a tone a few seconds later. It’s working too. :yum: Couldn’t have done it without ur help!

1 Like