Wyze Cam V3: IR Settings Not Persisting

I noticed this last night and did some further testing this morning.

I have 3 Wyze V3 cams and all appear to be exhibiting the same behavior. I’ve owned these for a few months now and I don’t remember this happening when I first set them up.

On each cam, Night Vision is set to “Auto” and the IR lights are “Off”. I set the lights to “Far”. When I back out of the settings page and then go back in, the setting appears to stick,

However, when I close the app and go back into the camera’s settings, the IR lights are set back at “Off” again.

I’ve tried restarting the camera and reinstalling the app with no success.

It’s daytime here now but I don’t THINK this behavior is by design. Meaning, I think “Far” means turn the IR lights on when it’s dark enough vs. turn the light on now. In other words, I don’t think the camera should be changing these settings automatically.

Or maybe I’m just confused?

change the auto setting just above the live view on the top right and see if it sticks when you change it there. the far setting will only matter if you have the IR leds turned on though.

on the V3 there are actually 2 sets of night vision IR’s. one labeled near and one labeled far. they operate at different wavelengths and thus one travels further than the other and so the “far” setting leds will project farther giving you better night vision if your camera is positioned say outside and you are trying to illuminate something across a farther space. as a by product of these different wave lengths one ( i don’t remember which) is NEARLY , not completely, but nearly imperceptible to human vision if it is on and you are looking directly at/into the camera. where as with the other setting on you will see the small “pink/redish” leds illuminated rather easily.

something tells me that the setting isn’t sticking because you have the leds currently turned off though. just a guess. make sure to turn the leds on first. then adjust the near far setting to what you want. ( sorry is I misunderstood the steps you have been taking)

I appreciate the response but I don’t think that’s the problem.

I did change the Night Vision setting from “Auto” to “On” and then “IR Lights” from “Off” to “Far” (same thing happens with “Near”). When I close the app and re-enter the settings, the Night Vision is still “On” but the “IR Lights” are now “Off”.

The same happens with the “Night Vision Conditions” setting. It’s currently set to “Dusk”. When I change it to “Dark” and re-open the app, it has changed back to “Dusk”.

Can anyone else reproduce that behavior?

this might seem silly but how long before you back out of the setting page are you waiting? we had the issue quite some time ago when you had to give it a second or the settings wouldn’t be uploaded to the cloud and saved so it would appear that you hadn’t changed anything.

personally I would also clear the app’s cache before I try again. i dont know for sure it would help, but it’s worth a small shot.

what device are you using by chance?

1 Like

are you Android or iPhone. Another option you can try, is to do this from another device. I have had an issue in the past where a setting on my Android phone was not sticking. I used my iOS device and it worked fine and the Android reflected the change.

@Bam: I thought of that (and saw similar suggestions in other threads). I’ve stayed on both the Settings and Advanced Settings Pages for minutes (way longer than I’ve needed to be on those pages prior to this issue) … and still have the same issue. If I keep a V3 cam actively loaded (regardless if I’m looking at the live view or a settings page), the IR settings persist. If I navigate away from that cam to view a different cam or close the app, the IR settings.

I’m using a Samsung S20 with Android 11.

@spamoni4: Good suggestion, but not possible in our family. We’re all Android users!


sorry about that. I assume it is happening on all the other devices as well

Yes. I’m having the same behavior on all 3 of my Wyze V3 cams.

I chatted with Wyze support and tried a factory reset and a firmware downgrade to .252, but still having the same problem.

Now waiting for a response from Wyze.

@Mattbrav are you running the beta version of the app? I am and don’t have the same experience you are having. If not, would you be willing to join the beta group, load the Beta app and try from there? This could rule out the app.

If you are interested in trying, you can join the Beta group by going here: Become a Beta Tester – Wyze

You can test the new app and see what your experience is like. then you can always opt out of the Beta Group and load the prod app again.

@spamoni4 Good idea and thanks for trying to reproduce on your devices. I updated to the beta app (2.21.14) and installed the beta firmware ( on one of the cams but still having the issue.

Definitely seems to be some sort of account/cloud setting that is “stuck” ?

Interesting. Sorry I could not help.

Okay, this is peculiar. I know we’ve had similar issues before in the past so I think I’m going to call in the big guns here and see if any of them have an idea

I really need to photoshop a @Mavens signal lol. Any ideas?

Years of experience between us I think somebody might have a good idea here. I was kind of hoping for a simple thing such as an older device but that is not the case.

I’m going to go for something really silly to try just because it’s also simple. When’s the last time you restarted your device? I recently had an issue and I tried and tried and tried and of all things I went to work and shut my phone down and as soon as I started it back up my issue was fixed. Considering all the troubleshooting you’ve done now I’m going to say you’ve done that already as well


@spamoni4 Thanks for trying!

@Bam Thanks as well. I’ve had V2 and V3 cams for a while and this is the first major issue I’ve had … and I agree, it’s a weird one. Actually, through all this I had NOT rebooted my phone, so good idea. I had removed/reinstalled the app (and then installed the beta app). Unfortunately, I just rebooted, and no change.

I sent logs to Wyze … I’ll update the thread if I hear back.

Was able to do more poking around now that it’s night.

Good news is that the camera is responding to the IR settings change … it’s just not reflecting the change in the app on a persistent basis as noted above.

So the app says the IR lights for all of my V3 cams are off but they are clearly on “Far” because I can see the red lights and it’s fairly obvious from the image.

Def looks an app bug. Not particularly bothersome, just confusing.


That’s strange. I’m using the Android beta 2.21.14 app as well but my setting changes and stays changed even when I close and reopen my app. I have FW on my v3. You would think if it’s an app issue then more Android users would be experiencing it. I can’t reproduce it.

I did have an issue where I didn’t see the green selection dot move when I changed from dusk to dark but the setting still changed. However, now I’m using it and I see the green dot move.

1 Like

I concur. :+1: The problem is if you make other changes on the same page when IR settings aren’t correctly reflected, the IR settings sometimes unknowingly change to the incorrect settings.

I’m also running Android beta 2.21.14, but am running beta on all of my v3 cams. The problem isn’t consistent across my 28 v3 cams… all but 2 have the problem even though they’re all running the same firmware. I’m seeing this problem in Android production 2.20.21 and all flavors of Android beta apps except one. And the problem is not limited to v3 cams in my beta apps. That’s a big problem as it migrates across the board forever unless fixed. I’ve submitted issues in CC and I’m pretty sure dr.know has also.

1 Like

I confirm this is an issue for me as well. I noticed that maybe a week ago and did the same test to find it’s listed wrong in the app but the lights are on.

I also have the issue and may have a workaround. I’m running Android 9 with app ver 2.24.51 and v3 cameras with firmware It turns out that the issue happens when I group my cameras. If I delete the group, my IR settings seem to persist fine (both the Near/Far and Dusk/Dark settings) on the individual cameras. So dear Wyze developers, please test the problem with cameras configured in a group.