Wyze Cam v2 won't stay powered on

I got my Wyze Cam v2 yesterday. Set it up and it was functioning fine. Then I accidentally unplugged the power cord. Now, after many attempts, the power won’t stay on on the camera. I have upgraded software, power cycled it, tried a different cord and outlet, etc. When I plug it in, the yellow light comes on on the back and stays solid. Never blinks. After about 15-20 seconds, the camera powers down and shuts off. Nothing I do can get me further than this.

Double check both ends of the power cord, is either end loose? When you say the camera “powers down” can you please describe what you see happen that tells you that the camera has powered off?

The camera clicks after about 15-20 seconds of the yellow light being on, and then the camera clicks again, yellow light turn completely off, no power. And yes, both ends of the cord are firmly connected, have tried 3 different cords as well

Ok my cameras all do that as well, it’s normal. The camera is not actually powered off. When you open the Wyze app on your phone can you connect to it?

I’m now getting all the way to the “Connecting” screen where it spins for about 150 seconds. Has cycled all the way through that a couple of times, keeps getting to the “timed out” status and prompts me to retry…at least it appears that your diagnosis that the camera is really not “off” is accurate, but I still can’t get it to connect! :frowning:

Excellent! Forward progress anyway! Are you using Android or iOS for your phone? If it’s iOS then force close the app and relaunch it. Same on Android but I don’t know the specifics for Android.

IOS. OK, I relaunched app and I finally connected!! You, sir, are a wizard! Or, I guess that’s a “maven” :slight_smile: Thanks man!


You are very welcome! Not a wizard just a happy user that likes to see other users happy!:grin::grin::grin:


Mine does the same , but am not able to get the setup button to do anything it just turns off the yellow light and turns it back on for about 20 secs , i have removed the sd card and tryed other power sources, it does the same…
I am going to try reinstalling the app on android to check if that helps, i have deleted the device from the app but it still does the same…