Wyze Cam v2 unresponsive after firmware upgrade

I have done that at least 3 times on the last firmware and 2 times on this new “fixed” firmware. Factory reset does nothing to resolve the issue.

I did resets, I removed from the app, I did adds back to the app after resets. I’ve tried all the suggestions over and over with no fix. I was working with Desmond last week and pulled hardware logs and sent those over as well.

When I updated the cameras to the new firmware this morning, even the “working” ones had to be “soft added” back in before they came back online. I had to reboot them, push the setup button, add them to the app with the same name and they seem to be working ok since then. The 2 problematic ones, that didn’t resolve it and neither did a factory reset.

Will it revive the three dead cameras, killed by the previous firmware upgrade @WyzeBaohua ?

1 Like

Thanks for the feedback. Do you mind PM me the router brand and model you are using? We want to do further investigation on this case. For the two problematic ones, if they are still offline, do you mind help us getting another SD card log files from them? Thank you very much.

If the LED light is solid yellow. Please try to manually flash the firmware to recover them. Here is the instruction for firmware flashing, https://support.wyze.com/hc/en-us/articles/360031490871-How-to-flash-your-Wyze-Cam-firmware-manually

I’ll send a message to you now.

I want to flash older stable firmware, but it is not available, this is the message on the firmware page:

Due to the security improvement on this firmware, you will need to go through the setup process for your camera if you go back to firmware or below. Because of this, we are removing those firmware files from this page.

older firmware still available.

read this thread


I’m pulling it now to flash, thank you.

@WyzeBaohua I had a camera that was “stable” for a few minutes until I rebooted it. I’m flashing old firmware and rebooting again

@WyzeBaohua it does not work, sorry. The LED stays yellow/amber, disappears for a split second roughly every 5 seconds. The camera clicks rhythmically, there does not seem to be a way beyond this point. I tried holding the reset button for probably 2 minutes, I tried holding it before plugging in the power. I tried both with and without the SD card that has the older firmware - nothing. 3 out of 10 cameras died in the process and the support’s reaction was along the lines of “too bad so sad”, so I am out $150. :face_with_symbols_over_mouth:

1 Like

I tried to flash the older firmware and the light never goes blue on my V2. Reading through that other thread it seems like this isn’t just a “me” issue.

1 Like

Sorry for the trouble. Could you please PM me the MAC of your device? I will follow up with you there. Thanks

@WyzeBaohua Done. Thank you.

Can the MAC serial number disappeared in Wyze server?
Why would that happen during update?

The MAC is on the sticker on the bottom of the camera as well

I was thinking the MAC address that Wyze used to mask over the OEM MAC address disappeared after 1433 or 1472 firmware flush.

My theory is that This is why no connection even after back down to older firmware. as Wyze server only responding to their Mask Over MAC address.

I think Wyze can push a MAC patch through their server.

I suggest everyone with problem should submit a log.

also Wyze mentioned in another thread regarding wifi password can only be 21 characters in new firmware

It’s 100% the long WiFi password issue. I was able to connect to one of my other SSIDs with a password shorter than 21 characters and it worked just fine after reboot.

I just flashed the older firmware on my 2 V2s that weren’t working to stabilize them until there’s a fix.


1472 just bricked 3 V2s :tada:

1 Like

Just spent the morning changing devices to match a new shorter wifi password, and resolved everything running latest firmware across a variety of Wyze cameras (Cam v2, Pan v1, Pan v2, Cam v3)

Wyze, y’all need to get your act together. I followed the troubleshooting steps in the app and submitted logs, downloaded the RouteThis Helps app and submitted that - then support came back with “Sorry, it must be irreparably broken, we’ll give you a coupon towards a new device.”

That’s very wasteful to trash a product that is working just fine except for a firmware bug. Document that you only support WPA passwords shorter than 21 characters in your documentation, and let your support know to ask/try that as a resolution step.


YES! This should be a pinned post, obviously listed as a limitation on the firmware page, and maybe even the phone techs should be told about it…

Screw-ups don’t necessarily alienate customers, but how a company handles them sure can…


I’m giving the benefit of the doubt for now given that the 2 people I’ve talked with from Wyze say they are still working on a fix.

That being said, I agree that this firmware needs to be pulled until the fixed firmware is out. I am personally not going to change 30 other devices WPA keys just to accommodate 2 prod and 1 test camera that I have that are experiencing the issue.

1 Like

So, any chance this could fix the three nonresponsive cameras I was about to send to an electronic waste depot? Or is the solid yellow led the same as the “blue screen of death” on a PC?