Wyze buds pro won't charge

When I try to charge, with either a charger or the inductor charger, the light on the case turns yellow briefly and then doesn’t seem to charge.

I think I have updated everything. Any suggestions?

1 Like

You said it turns yellow briefly, then what does it do? Does it turn off?

I would try a diffrent cable, outlet, and power adapter

1 Like

Thanks for the reply. I saw this in the support it does none of this. It turns off.

Brielfly yellow then turns off. This behavior is the same with earbuds in the case or not.

I found this too - Wyze Bud Pro Case not Charging

And I have tried several chargers of different types and cables, too.

That’s odd, is this the first time it’s done this, or is the device new and it has never worked?

Have you tried wireless charging? Could be an issue with your charging port?

If Wireless charging does work, then I would infer an issue with the charging port.

I would give Wyze Support a call/ticket either way.

@R.Good - wireless (i.e. induction) also failed .
@IEatBeans - the failure has happened before but I think think I stumbled to a fix without knowing how.

Follow up with support - “Reset case by holding button for over 20 seconds, then try charing.”

This did work. So hopefully that won’t be necessary each time but we shall see at the next charge.

Thanks for the speedy feedback.

3 Likes