Wyze Bud Pro Case not Charging

Hi, is anyone having this issue with their case not charging? It’s only charged successfully once. Otherwise, the case is always dark with I try plugging it in to different cables and outlets and even on my computer. When I detach it, the case light is still yellow. I thought maybe the light was broken and just left it attached to a cable all night, and it still has this issue. Thanks!


I have not had any issues with charging the Bud Pro’s. I have plugged it in and even charged it via a Wireless charger.

Have you tried removing the buds from the case and reseating them again?

1 Like

I am having the same issue - nothing I do will get the case the charge - I’m at red now and worried this will be the end of my Wyze buds pro

I am having the same issue. Wyze Buds Pro case is not charging. It’s yellow and shows yellow on the app.

Same issue here, any support?

Same issue. I opened a support case and am awaiting resolution. I pre ordered my Wyze Buds Pro when they were first announced, received them a few months later and have been working great up until this week. Should still be under the 1-year warranty, so we’ll see what they do. Will update here.

Same issue. The case on the app shows 7% and not charging at all. The buds themselves are charging though.

I am also having this issue. Why hasn’t Wyze support responded to anyone?

Resetting the case seemed to have worked for me. It’s back to charging normally now.

As a quick update, my Wyze Buds Pro were under warranty, and Wyze was quick to respond and replace them with a new pair. Very happy with the support received.

Thanks for the update. I’m going to hopefully utilize the update as well. Hopefully the next iteration of these won’t have this issue

Not to resurrect an old post but it was in the top of my Google search. I keep my case in my pocket mostly and figured it might have lint and stuff in the usb-c port. I didn’t see any but thought I’d go that route first.

I had this issue and just fixed it by wetting part of a paper towel with 91% isopropyl and using a toothpick to guide it in the usb-c port on the case, on both sides. This apparently cleaned the contacts enough to allow it to charge again.

Quick Edit: This also must have somehow been interfering with wireless charging too. Wireless charging did not work before cleaning but worked after.

Im having this issue now. I cleaned some lint out of the charging port but still get no charging light. The earbuds themselves seem to charge and when I unplug the cable from the case I get a red light for a couple of seconds.

I had the same issue, and fortunately the same result. Orange light and not charging either wirelessly or wired. I cleaned out the contacts (toothpick and nail polish remover) as well as any lint, and it worked again. I was also kind of surprised that the lint or dirty contacts would prevent wireless charging but that seems to have been the case. Weird.