Wyze app 2.45 Beta Test 8/21/2023


  • Android: 2.45.0.b333
  • iOS: 2.45.0 (3)

What’s New:

  • Added support for Oauth login
  • Added support for Google and Apple ID login
  • Optimized Bluetooth communication on Android 13 devices (Android-only)
  • Fixed the -20 error that occurred in camera livestreams on some Android devices (Android-only)
  • Fixed a crash that occurred when opening Wyze Cam OG Event push notifications (iOS-only)
  • Bug fixes

It’s showing up in Google Play already. I just installed it. I’m not sure I’ll notice any of the above-listed differences, but I’ll keep an eye out for anything I notice.


The app made me log in again after download, not a big issue by any means but thought I would mention it.

I am still experiencing the cam plus filter problem that popped up two beta versions ago. I understand that the team is aware and working on a solution but I wanted to mention it just in case. I am on a Pixel 7 running android 13’s latest update at the time of posting.

I did notice that the Livestream seems to load faster which is always a welcome improvement!


Unable to log back into the app. After putting in the 2 factor code, I get the following error:

Invalid client or context, please access login page through Wyze app or official website.

Request Id: c249ff35-c48f-413c-a7f1-5d94b1d5f72f


Loaded the app on Android and currently have no issues. Will perform testing.

Note: The App startup, after install, presented with a colorful Wyze Logo and I had to logon again, as others have. Not a big issue for me. :slight_smile:


Cannot rename my V2s and PansV1. No issue with my V3s.

Same issue with 2.44.5(iOS).

Oh! Fancy! I am loving this design in Darkmode

It was also really nice to be able to login just using my Google Passport instead of having to dig up the Authenticator App.


Anyone know if when viewing Cloud Event videos from earlier in the day, are taken back to near the most recent videos or back where you left off went you use the Back button?

1 Like

What is the matter with Wyze? Why they keep messing with the GUI? In a group view on iPad, why did they added the gray bar at the bottom of each camera view featuring the speaker icon only? When screen real estate is at premium, it’s counterproductive to take away of it. Why they didn’t leave it alone as in before (see screen shot below). It’s not like we have the luxury of viewing our cameras on a big monitor or TV screens. We view them on a puny phone and tablet screens. Come on Wyze, hire a good GUI designers, don’t let programmers design your interface.


Just wanted to report that with iOS 17 public beta the Wyze app is totally nonresponsive. Nothing can be clicked at all. The app loads and I can see my camera groups but I can’t get to anything. I can’t even check to see what version of the app I am using,

Update: I tried reinstalling and still have the same issue. I’m pretty sure this is a problem with the iOS beta.


Two problems with OAuth on iOS:

  1. It now tries to prefill from my keychain my Amazon credentials. This requires having to open the passwords panel and type in “wyze” to find the proper entry requiring a bunch of keystrokes instead of one click as before.

  2. One-click fill of the 2FA code no longer works. This requires switching to Messages, memorizing the code, returning to Wyze app and typing it in. Again, many more keystrokes than the previous one click.

Together, these seriously degrade the ease of logging in on iOS.


Its easy to do. UI thread blocking in apps will cause that. The user can’t do anything as long as the UI thread is blocked. Apps are very fragile. The app obviously worked through sign in and up till that point where something is blocking the UI programmatically.

I take it that they can reproduce it in order to fix it or otherwise you’d keep having that happen in future updates.

1 Like

I noticed this as well. It seems like the app is using a very different login page than the website, and this new one doesn’t have the proper type and id attributes set in the fields so your phone knows what to fill.

Hopefully they fix that soon, because the login with google is very nice.


Additional info on my problem:
Galaxy S20 FE 5G
Android 13
Uninstalled and reinstalled app
Cleared all data/cache in app
Tried on my WiFi and Mobile data
Reset password

Just discovered that it does know if I put in an incorrect code from my authenticator

If I put in the correct code, I get:

Invalid client or context, please access login page through Wyze app or official website.

Request Id: 5de19f49-5e87-4239-a91a-16d44ad3c28d

1 Like

This was due to the changes to the log in.


We are still working on resolving this issue.


There is an issue with the iOS beta that we are still trying to resolve.

Edit: I am being told that iOS beta 7 resolves the issue of not being able to view groups.


Everyone who upgraded to the 2.45 beta can you tell me if you had to log in after the update or were you automatically logged in?


Yes, I had to log in again after the update to the beta on my Pixel 5