Wyze Account Access

I’ve used the same password for awhile. Today it suddenly won’t let me logon. Says bad password. I went through the process of changing the password multiple times. Still won’t let me logon. I was able to logon to the web site with the new password (doesn’t recognize the old one). WTF! If there is a system malfunction then it ought to say that not put you down a password path. In the meantime I’m really beginning to think the whole Wyze thing is about as reliable as a house of cards in a hurricane. Time to rethink my camera strategy.

1 Like

Are you using a VPN? Please disable your VPN and try again

Sorry you are having a problem, but here’s a petty good rule of thumb for these type situations.
If you have not changed your password, and it won’t accept your password, the problem is likely not on your end/side. Best to just wait, don’t do anything. You are right, its probably a system problem. If we wait a while the system folks will like resolve the problem and then we can log back in.

In the meantime, “you can’t get in”, to read the notice that says, “its not your password, its the system that’s preventing you from getting to the announcement that says, its not your password”. As a another rule of thumb, the hint to us that the system is down (for those of us not using 2 Factor Authentication), is the password prompt. If its asking for your password, its like a down system problem. Make a little more sense?

The app login is going to NOT be the same “doorway” as the website. So, even if the app login is not working, and the website login is, that doesn’t mean you should change your password. Because now, when the app system side is fixed and available again, you MUST use that password you changed on the web side.

This example might help. You installed an electric front door lock. And it works for years. One day you come home, and it doesn’t. But you can go around to the back and use your key. Key works and you get in. Certainly no need to rekey the back door or the front door, when it was likely the batteries in the lock’s electronics. I just throw that out for others that might need the example. I think you already had it figured out.

I am having the same problem for ~ 24 hours now. Have tried every thing. I know it’s a problem on their end but when I talk to support no one seems to have a clue.

Not being able to use the app is infuriating. Does anyone know when this will be fixed?

Wyze - a meaningful transparent update would be appreciated!

Have you tried disabling your vpn, or using a diffrent network to login?

Yes, even different phones… and I’m not on a VPN.

In my case it did turn out to be the VPN. This didn’t make sense from home because that is a trusted network and shouldn’t be on the VPN. It also didn’t make sense from the car because that is cell and I don’t need VPN on the cell network. Not sure what’s going on with my VPN. On another front, it makes no sense that I can’t do this through a VPN. So they’re saying that if I protect myself on an untrusted network then I can’t access my home system. That’s really bad news.

Yes, that’s not right. VPN shouldn’t be a problem. Neither should being on a wifi vs cellular network.

I figured out the problem. (Mine, at least)

Basically the 2fa had to be disabled. It is the cause of all tmy login problems. It just doesn’t work on Android.

I tried 3 different networks, and 3 different phones, all pixels: 4, 4a and 6Pro. None of them allowed me to login or change password. The only error I got was a message at the bottom of the screen, “failed.” (I was not on VPN at any time.)

This morning I got a hold of an iPad. Magically, the 2fa worked there and I was able to change my password and login.

Then I tried all 3 Pixel phones with the new password and none would work.

Believing 2fa to be the issue, I then went into my account on the iPad and disabled 2fa entirely.

After that, I was able to get back into my account on the Pixel devices with my new password.

This has been a nightmare and terrible customer service that went on for a week back and forth.

Wyze, please fix this so more people don’t have to go thru what I did!!!

We can’t fix it. I hope you begin to understand that this is just a customer forum. Other users like yourself come here and share how-to’s, ideas, and our experiences figuring stuff out. The Wyze social media staff shows up once in a while to share some PR with us. Otherwise if you are seeking to bring to the Wyze techs an issue that needs to be addressed, you must contact Wyze Tech Services. We can’t do that here for you. Sorry.


Oh! So I’ll do that. Thank you!

I was going through something similar the other day. The app would not let me login, it kept saying invalid password when the password was correct… turns out it was the VPN. I generally always try to access apps without a VPN because of reasons like this.

I’ve had this issue and it is a pain. I have a vpn client on my phone but not currently logged in. My mother has been hospitalized and I’m trying to watch her home and mine and whenever I try to log into either account it makes me change the password before I can get in when I know I’m using the correct passwords. I can get though using live view from a web browser but it is a royal PIA.

iOS app was compatible with VPN on iPhone until now. Latest update no longer allows to log in when VPN is on, which is impractical to turn off every time to look at Wyze App. It would be great to restore compatibility, even with a separate setting.


I agree this is annoying. However, it should only affect you during the login process. Once the app it logged in, you should be able to access it almost indefinitely without turning off your VPN. This is assuming you don’t manually log out the app each time you stop using it. Is this not what you are seeing?

I have been told that Wyze is intentionally blocking access via certain VPNs that are known to host scammers/hackers/etc. Wyze is firm on this issue and will not change it. (My personal belief is that this makes us less secure, not more.) That said, I am told that if you email security@wyze.com, they may make an exception and whitelist your VPN. I haven’t tried that myself (yet).


It also helps to use trusted, reliable and well known VPN, none of the free and fly-by-nights.

Thanks for your advice. I use NordVPN, one of the most known in that business.

| habib
March 27 |

  • | - |

It also helps to use trusted, reliable and well known VPN, none of the free and fly-by-nights.

So Nord VPN is not a trusted VPN?

Many VPNs use the same data centers, so if malicious activity is detected at a datacenter one if it’s IPs might be blocked for any users. That’s what makes VPNs so hard to safely allow.

I ve been using NordVPN for years and never had any issues.