Is password reset broken on wyze?

The URL in password reset email takes me to the page, but before I can enter 5 digit code, it showed:

  • This key is invalid or has already been used. Please reset your password again if needed.

I tried 10 times but now I am unable to access my video. Very disappointing to know the can’t even have a functional user databases.

I’m having the exact same problem, what’s up? For security reasons, really need to reset my password but it won’t let me out of this loop?

I’m going to send a note to Wyze about this. If there are additional details you can provide, please do so in this thread. Thank you! :slight_smile:

1 Like

Have you tried clearing the web data (eg cookies, etc)? Or perhaps try a different browser?

also it is weird that I can use the same password to log in the wyze app from another phone but can not log in to wyze website.
BTW, password reset page failed on multiple devices and different browser. It is a problem on wyze side. I can not understand (had a case opened) why no one is fixing it

It is being worked on. I received a message today saying they were aware of the issue and were looking at it. :slight_smile:

1 Like

I tried Chrome on the phone and Firefox on PC

Same result. The page for password reset didn’t show up at all. The page should provide form to type the code but I got this error right away