Wifi83-2G network?

I have Wifi83-2G. I bought WYZEC3 recently and I have been trying to set up my Wyze device. I tried 2 or 3 times, it says "Cannot connect to local network. Any suggestions?

What exactly is that? Assume from your post you have an iPhone. What brand/model of wifi router do you have? What exactly did you try in order to connect the camera? Did you verify it is a 2.4Ghz network? Confirmed SSID and Password are correct? Is this your first Wyze device?

I am not an expert but trying to be one. I have MySpectrumWiFi83-2G. This is my Wyze device. I found out from some local seller that my Wifi is compatible with WYZEC3. I bought the model. Now I have been trying to set up the device 2 or 3 times. I got the reply: Cannot connect local network. AT SSID I typed one time: WiFi83-2G and when the connection failed I tried MySpectrumWiFi83-2G full. Even then I got the same reply. I have iphone 7 plus. Can u help. If I could set this up successfully, I intend to buy 2 more. Thanks

I suspect this may be the problem:

All Spectrum routers support 2.4 and 5 GHz frequencies. If the router has a single WiFi network name, the advanced router will select the correct connection for your device.

You are most likely connected to the 5Ghz and not the required 2.4Ghz. The camera needs the 2.4Ghz and won’t connect to the other. On the bottom of your Spectrum router does it show two SSIDs or just one? If two, select the 2.4Ghz network for your phone.

You may need to do some research to see if you can temporarily turn of the 5Ghz.


Yes, Spectrum supports: MySpectrumWifi83-2G & MySpectrumWifi83-5G. I have the first one and I entered the first one only: My doubt is should I use the complete MySpectrumWifi83-2G or Just Wifi83-2G. And also for the pass word, should i enter the default pass word or else the new pass word I reset. Thanks for the suggestion.

I already selected that one for my I phone when doing the settings.

My router has 2.4 and 5.0. In settings on my iPhone, Wi-Fi it shows both net works. It uses the same password for both SSID.

Its customary for Spectrum to name the SSID for their 2.4 and 5 networks with that syntax. A couple of neighbors have asked me the same and we discussed it for their home network.
@sarojiniarani, you have to “select” the entire name MySpectrumWifi83-2G. You should not have to type it in, just select it from a list. There’s a password that came with your paperwork. Maybe taped on the router. You mention default pass or new pass word. You are talking about router, correct? It must be the most recent password. If you changed it yourself, then yes, new. Did you force it to reset the password?

Most routers when reset, return to a factory default password. You should NOT leave it on a default password. “Everyone can find that” and could compromise your network.

I encourage you to call Spectrum for help in accessing the admin account on the router and changing the default password to something unique only you know. Then with post-it note, put the SSID and password on your router top or bottom, so you know where it is.

You also might find help/instructions on Youtube.


Thank u very much for the response.