Webview Beta ... Clearly not ready for release

Signed up for Webview with the Cam Plus subscription service tonight. I must say it was one of the worst experiences I’ve ever had. Got it all setup in a few minutes, but then tried to use it and got nowhere.
Clicked on the live stream for all three of my cameras and they just sat there an spun an hourglass. Never managed to connect. Immediately requested a refund. Clearly this service isn’t ready for release yet!

FYI, common causes of the just spinning issue are:

  • Using Firefox - it’s not supported yet, but is in the works
  • Upload speed bandwidth issue from the local ISP
  • EDIT: As discovered below, RTSP firmware also does this

They’re working on solutions to both issues, so hopefully in the future it will work better for people by the time it is out of beta testing.

Using 1Gbps upload and download with a good router and modem on Google Chrome I have had over a dozen cams streaming well simultaneously. So we know it can work well, they just need to fix Firefox for those of us that prefer it, and fix the upload speed issues by allowing a variable bitrate based on what’s currently available. Then we can all use multiple streams at a time.


I’m using Chrome and I have a 500MB fiber connection, so I don’t think either of the issues you identified apply in my case. Seems like I’m closer to what you have and only 3 cams

Hello other tony, What cameras are you trying to use?

Wyze Cam V2

Thanks for reporting, that would be frustrating. I agree with you, neither of those issues should apply to you. You should have more than enough bandwidth. What firmware version is on your cam? Maybe we can find a pattern in that somehow. I do have a couple of V2’s that act up a little lately, though I"m often running a few different firmware versions. Maybe we can figure out what else the devs can look into.

Cams are all running Firmware / Plugin

1 Like

So RTSP in all your v2s? That may be the issue. The RTSP firmware branch is a beta branch of firmware, and doing so negates you from having access to any future features. More info on that below:

If you wanted to I would switch one of them back to production firmware then try again with the beta webview.


This was very helpful. We now know another variable that causes the spinning hourglass (RTSP firmware). It will be helpful in asking others who find problems using the webview. Hopefully Wyze can work out a way to make it compatible with the RTSP firmware in the future once they’re aware of this.

Thanks for sharing @tony1 this was very helpful knowledge, and thanks @Omgitstony for figuring out the above information. Great job.


I use the RTSP firmware so I can use the cameras with my ZoneMinder setup. It’s a home system that I don’t have to pay $ each month to see video on the web and record events. Unfortunately it only. works marginally well with the WYZE cameras, so I was hoping their built in solution would be better. However, I’m not willing to give up RTSP in the short term so I guess I’ll have to wait for a version of the firmware that supports both.

I have one V2 on RTSP firmware, and it streams live without issue for me in Webview

I don’t know if the “RTSP is not a stock feature” statement includes the V3’s on RTSP firmware or not, but my six V3s all seem to work in chrome for me, albeit not consistently.

I wish it worked for my Video Doorbell and my WCOs


1 Like

Interesting, SJ, thank you for posting this. Hmm… I wonder what the difference could be then. Hopefully beta can help narrow some of this down.

I even read some guys claiming Firefox had always been working for them for this, but it doesn’t fit most people. Interesting that there appear to be more variables involved than we’re aware of so far.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.