Vacuum cliff sensor bypass

I pre-ordered and have received our Wyze Vacuum and am pleased thus far. There are a few minor things I would love to see, but I am focussing on this one topic. We also own an iRobot Roomba 692 which is a model that wanders aimlessly, but does a decent job.

Both robots share a common problem. We have an area rug that is bordered with black and has black in various areas. See here. Both vacuums detect this as a cliff and will not enter the area to vacuum. If we place the vacuum on the carpet it just “bumps” into the black and changes direction.

Much like you can create a virtual wall, I would love to be able to define a “Safe zone” indicating it is free of cliffs/drops/stairs. It is conceivable that this could even save battery :wink: .

I hope this will be considered. I am a compete Wyze-ophile. To date I own 7 cameras, various sensors, Vacuum, Headphones, Outdoor plug, Indoor plugs, pre-orders for Door Cam and Watch. I cannot tell you how many other products I have encouraged others to buy. I care say I could call myself a true Wyze Evangelist.

Keep well.

1 Like

Just got my Wyze Vac yesterday. Same issue with black carpet. Thanks for posting noticing this counter-intuitive behavior and alert us. I was really scratching my head trying to figure out what on earth was going-on.

1 Like

Explains where the space heater went. :wink:

The existing mapping edit functionally should be enough - you tell it trust me, this is a floor. Surprised it’s not that simple.

I don’t understand what “space heaters” have to do with the “black carpet” limitation of the Wyze vacuum?

I was just being snide. A Wyze product manager came to the forum last year for a survey about a potential new Wyze space heater. The reception was not… warm.

Now I understand. Thanks for the explanation. :upside_down_face:

1 Like

Can someone post a picture of the location of the IR cliff sensors?


I had to physically maim the cliff sensors on my old Roomba to stop this over our dark floor and heater grates. It would be such a simple software switch!!!

1 Like

This Wyze Webpage shows the sensors: Wyze Robot Vacuum | Cheap Robotic, Automatic Vacuum with LIDAR

1 Like

Thanks, that is what I was looking for.

If we can’t have this feature, could Wyze at least update the product description to say WARNING: DOES NOT WORK WITH BLACK CARPET, TILE, OR ANY OTHER DARK COLORED FLOORING.

1 Like

This hack worked for me just now. 4 pieces of duct tape and 4 pieces of tinfoil.


When I first tried taping the aluminum like you show in the photo above, then placed it on the floor and pushed the start button, I got the audible message, “Please check that my wheels are touching the ground and try again.” The buttons flashed red. It didn’t work. But, then I used a pen to lift the tin foil away from the plastic of the vacuum, creating a space (under the foil). Then, it worked. I’d post a photo, but this description for those who encountered my issue and your photo bigchipmunk should be sufficient.


LOVE the idea of a safe zone so I don’t have to disable the cliff sensors. For the Wyze folks, here is a screenshot of my map and a picture of my living room carpet so you can see how well the robot vacuum maps the black on the rug in the living room. Unfortunately, it does a great job! :wink:

1 Like

Just got the robot today. Was seeing bizarre behavior on one of my rugs, and then realized this was the issue. Glad to see I’m not the first to have it. Sad to see that despite this thread having started just shy of a year ago, this is still an issue.

I really like the idea of “safe zones”, but that would require a mapping run first, which would still fail since you can’t currently add such features until after an area is mapped. If there was an option to draw “safe” and “no go” lines on the map during creation, then that would be a reasonable solution. Alternatively, I guess you could move all your furniture, remove the offending rug(s), map, then replace the rug and all furniture, but that’s a LOT of work, especially if you have to remap later for some reason.

For the record, I’m currently running my 200S on the latest firmware 1.6.113.


What’s up Wyze? How hard would it be to just add an on/off toggle to the app?

1 Like

I had the same issue, in fact, the only issue I had with Wyze Robo vacuum.
I solved it by printing a cover for the cliff sensor.
More details here: Cliff Sensor Cover for Wyze Robo Vaccum by nishabe - Thingiverse
Hope it helps!


Thanks! I printed a set of these with white petg and they have worked out wonderfully!

1 Like

Excellent part design available on Thingiverse for those who have this vacuum, a 3D printer and black floor areas.

A big shout out of thanks to Thingiverse users: Yufu and nishabe for providing and posting information about the very professionally designed sensor blocker. I found the link to, from the above post from nishabe, It works great! The fit over the sensors is perfect. It is so much better and professional looking than the previous solution of taping pieces of tin foil to the bottom of the vacuum. I hope Wyze rewards the designer for that person’s ingenuity and expert design. In my opinion, Wyze should compensate that person(s) and then provide these four inexpensive parts either free or at a price point that could benefit the designers. Afterall, not everyone owns a 3-D printer. Well done Yufu and nishabe. :grinning:


These sensor covers are great! They solve the dark contracting carpet issues… but they don’t work if you still need the sensor to keep the vacuum from falling down the stairs. Wyze needs a software update to allow the sensor to be disabled in certain parts of the map and enabled where you need it the most so it doesn’t self-destruct down a flight of stairs.