Vacuum cliff sensor bypass

Good point. I also got stairs but I set a no- go zone around the stairs.

I purchased the robot vacuum in part, to clean under the bed. However, even though there is about 1/2" clearance and the vacuum clearly fits, it does not want to go there. Online support chat has told me that the reason is that it is too dark as the available lighting is very low. I feel that the product is mis-represented in that the WYZE FAQ states that the vacuum will go under any furniture that has clearance. It says nothing about the level of lighting playing a factor.


That’s interesting. I now have two different relatively-dumb robovacs and they have no such issues poking under everything they can.

Mine vacuums in the dark downstairs. Don’t see any technical reason for it needing light, the sensors are IR. The carpet is even of a dark color (but uniform). Mine will try to fit into places where it will get stuck on the LIDAR, necessitating a no-go zone, so it shouldn’t be having any issue if there is space above that.

1 Like

I did a test and covered up the IR sensors with foil per an earlier post. Sure enough it did go under the bed but then got stuck on the LIDAR sensor trying to come out a place where it didn’t have enough clearance. So for my purposes I’m convinced that the darkness does matter, and it is what the support tech told me during a chat.

Mine goes under beds just fine, however, when I mapped my house I made sure that all of the bedding was lifted up on to the top of the beds so that the lidar had a clear shot under the beds and could hit the walls on the far sides of the beds. I have not had any problems with the vacuum going under the beds even with the lidar running into the bedding that is hanging low enough to block the lidar. The cliff sensors are IR and they don’t need ambient light to operate properly which is a good thing considering that they are in the shadow of the vacuum and don’t get any of the room lights on them nor do they need it. I have 3D printed white cliff sensor covers and it has solved all of my problems, good for me, but it doesn’t help everyone else and Wyze should fix the problem instead of ignoring it.
All that being said, I would first try remapping with your bedding up and out of the way to make sure that you are not having a lidar problem unless of course you have flooring that is causing the problem. If that is the case then the only solution is to cover the cliff sensors so that they always receive reflected IR and don’t freak out on surfaces that absorb IR light. “The only solution” because Wyze is ignoring the problem.

1 Like

Cliff sensor room on/off option

As we all know smart vac’s cliff sensors have problems with black or dark areas on carpets causing them to get stuck.

Why has no one added a option to turn them off for specific areas once they have done mapping.

This would fix the carpet issue and still avoid falls in areas where there is actually fall hazards.

A simple fix that would make so many happy and requires no hardware changes.

[Mod Note]: Your topic was merged to this Wishlist request for better visibility and consistency in grouping similar requests. Please remember to scroll up to the top and click the VOTE button to show your support.

Tired of waiting, Replaced Wyze vacuum with another company version… No need to turn off the cliff sensors as they don’t stop on the dark grain like the Wyze did…

1 Like