Update App for Vacuum ( Network Password Option)

Please update the app so that setup for the vacuum will allow user discretion regarding the use of a network password. Some home networks are open and don’t require a password, but the setup for the vacuum requires a password. Please make it so that there is a choice to use or not use a password on the network.
Thank you.

[Mod Edit] Title Edited for Search Clarity

Open networks, in general, are a bad idea security-wise. Perhaps you have a dedicated, open network, for devices that don’t have access to any personal information and it’s OK, but for the most part, every home network where you deal with data that you care about should have a password.

This is great and all but in the case of my parents who live on a farm without neighbours for kilometres, we see an open network as reasonable.


Really loving the new Wyze vacuum, but since my home is rural I don’t have my WiFi network secured with a password. The Vacuum can not be connected to an open WiFi network. The setup dialog will not proceed with a blank in the password field. I have dozens of devices connected to this network and if I add a password I will have to set each of them up again. I really don’t see why the vacuum needs a secured network, especially when considering that my Wyze cams work fine with the open network.


Are you able to create a second SSID/network name alongside the one you use?
Some WiFi routers/access points allow you to do just that, and it’s something I’ve had to set up on my own network.

Torakhan, my router doesn’t support a second 2.4GHz network other than the guest network. There are ways I can work around this, but the point is that I shouldn’t have to unless someone can come up with a good reason why Wyze Vacuum shouldn’t connect to an open WiFi network. Thanks for the thought

Hi OldVMer,

I have exactly the same situation that you have. I live in a very rural area and have no need for a secured network. And, like you, I already have dozens of smart devices connected to my network, all with no issues. Ironically, I even have several Wyze cameras connected which, at least at the time I set them up, did not require a wifi password. I discovered the password requirement when I decided to order one of the sensor bundles some time ago. So now that Wyze is requiring a network password, I have had to stop buying any additional products from Wyze. Makes me sad because I do think they have some great products. But I really have to question the wisdom of their decision to require a wifi password. Granted, an unsecured network isn’t the safest scenario on the planet, but the choice of using or not using a password should be mine to make, especially considering that most smart device manufacturers support non secured network connections.

One thing that would be really handy is some sort of reference document that shows which Wyze devices require a wifi password and which do not. I’ve tried to find something like that, but haven’t come across anything so far. The new full color bulbs look really cool but I’m afraid to order any because I don’t know if they will work on my network or not.


If you don’t have a password then why not just use your guest network for this? I know all routers are different, but mine has an option to allow access to order devices on the main network so maybe yours might too ? (Best to look on the router’s web interface and not through an app)

Thanks for the suggestion. My guest network does not have a password either. Nor does the 5Ghz network. I could solve the problem multiple ways, but the point is, why shouldn’t I be able to connect the vacuum to an open network?

Oh you’re totally right about this, but it always helps to have several remedial methods in the meantime!

-Trevor Benyack

1 Like

I just discovered this is still a problem… my cameras are all fine with an open network, but not the vacuum. I guess the vacuum has to be returned.

Following up on my own post. I checked into the SDK and API documentation, and there doesn’t seem to be a way to set this up manually. Likewise, there’s no USB port documentation. Sad, but such is life.