Unable to change camera name

I just ran into an interesting problem. I can’t change the name on new cameras after initially setting it at setup.

Background: I have 7 V2 cameras and 2 Pan cameras. All the V2s are running firmware version, and the Pans are firmware version All of my cameras are named with a number followed by a hyphen and then the name of that camera location. For example, the first camera I bought is named: 1 - Dashcam. The Second is 2 - Bay window south. That way I can identify what physical camera is which. Since the cameras can be moved fairly easily, I can move the camera and change the name, but retain the number. I have a list of what camera number has what size and type of uSD card, when it was bought, etc. I also have the camera number P-Touch labeled on each camera.

Yesterday I received four new V2 cameras. I don’t know which camera will end up where, so when I initially set each one up, I just named them 10 - , 11 , 12 - , and 13 - (forgot the hyphen on 11). On each camera, I did the firmware update so they are all the same versions as the rest of my V2 cameras. This morning I went to change the name for two of them and the name will change, but then reverts back to the original name. I have tried changing the name both by clicking on the camera name in the device list, and also using the edit on Device Info screen.

iOS App version 1.5.50

Firmware version

Hopefully this video capture will show the problem. I tried to change camera 11 to a new name using both ways to do that and you will see that it reverts back to “11”. However when I changed camera 5 from “5 - Garage south” to 5 - Camera South", the name change was retained. Yes, my garage is a MESS!




Try doing a pull-down refresh of the Device list before and after the name change. If that doesn’t do it, try deleting the app from he phone and re-downloading it.

I don’t know what you mean by a “pull-down refresh of the Device list”. I don’t see any way to force a refresh of the list.


When you’re on the Devices page, with it scrolled to the top, do pull-down gesture on that page. A little more page will be revealed at the top and you’ll see a little animation of a Wyze Cam looking left/right/left/right. That is how you refresh the device list. (The device list is stored on the server under your account so that it will load on any other device on which you log into the Wyze app.)

Got it. Did not know the name… the refresh did not help. As soon as I would do a refresh, the new cameras would revert to the initial install name.

Un-installing and re-installing the app (via test flight since I’m part of the beta) did resolve the problem.

Thanks for that suggestion.


By way of explanation… it sounds like there was a conflict between the server device database and the locally stored one, or the locally stored one was corrupt. In either case, deleting the app also deletes all of its locally stored data and forced a re-download from the server.