Two Way Communications - Battery Cam Pro

I am a new owner of a WYZE Battery Cam Pro. I have it installed outside under the eaves by the front door. Tonight my wife and I tried communicating and found an issue. I was outside by the camera and my wife was inside on the cell phone. When I spoke to the camera everything I said was repeated by the camera so we ended up talking over each other while trying to hold a conversation. Note : I had her viewing on live stream. Our cell phone is an older model Google Phone. I have not activated an account with WYZE as of yet so this is all being done using the in-house WiFi while watching on live stream. Two questions… Firstly - is there a volume control anywhere in the app? Secondly - How does one eliminate the echo ?

If I’m understanding correctly you are speaking into the actual camera, and hearing yourself back from the camera speakers?

Yes - That is exactly what happens. Right after I would say something to the camera, everything I say is repeated back so during that time you cannot hear what the person on the app is saying.

Because it was playing on her phone but she had the microphone on thus it was then playing back through the camera. I’ve never tried having a two way conversation on my cams but my guess is they have not implemented anything to prevent this (like conference calling apps etc do) so you need to turn off the mic when listening and turn it on to talk. Or in technical terms, you can’t use them in “full duplex” mode, you have to manually do half duplex. You can submit a feature request for them to implement full duplex/cancellation but I doubt it is high on their list.

Think of old school intercoms, you push only when you want to talk. Same goes here.

That would explain it… Thanks for the input. I guess the best bet is to simply use it as one way to talk to the person on the screen and not attempt to have them talk back. The problem with trying to turn the microphone on and off is that the microphone button disappears unless you touch the screen over and over and it is very tiny at the bottom of the screen.

I don’t use mine for that function, but tapping the phone screen brings the icons up, yeah a bit of a hassle, I’m assuming it isn’t a big enough feature for them to try and implement full duplex DSP and noise cancelling. However you might try using a headset if you want to use the feature as that should eliminate this problem (yeah, still a bit of a hassle, but potentially workable). A bluetooth speaker that has a mic (like alexa) may actually work, many of those have simulated full duplex built in, but not sure if it would play well with the wyze app.