Trying to purchase a sense kit

Hey, I’m trying to purchase a sense kit but whenever I go to my cart to checkout i get an error message saying “invalid key, refresh failed” and I cannot continue with my purchase. It’s been happening for the last 2-3 days.

Has this been happening to anyone else?

@ThaDentist Are you using the Wyze app to make a purchase or the site?


Was using the site, switched to the app and it worked, I completely forgot that you can purchase from the app. Thanks!


You’re welcome! That’s great, glad it worked for you. :+1:

1 Like

Been trying to make a purchase on the website for weeks… found this and tried the app. Get this message: “We are currently performing maintenance. Please visit to make purchases, browse product information, and contact us. Thank you for your patience!” Haha!

I want to use and love Wyze, but it seems the universe is against it! ;p

Are you getting an error at the website? I just ordered two motion sensors on March 8 and had no issues. Yes, the app hasn’t worked in a while…

I am getting an error. Using Chrome, but had the same issues with Safari on my Mac and iPhone.

1 Like

I used Chrome for my purchase. I reckon someone from Wyze should address this, then.


1 Like

I’ve found a work around on IOS. I downloaded puffin browser and it worked.

Good to know since I’m migrating from Android to iOS in a few days.

1 Like

It’s $5 but for life. And it’s a great browser. Plus they update it often. You can select mobile or desktop version too. But I was only able to order from Wyze using the mobile site on puffin. I already passed this on to @WyzeGwendolyn

This entire experience is not inspiring confidence in Wyze… I really would love to use the product, but I can’t add in sensors no matter what I’ve tried. I’ve cleared my browsing history on both Safari and Chrome. Cleared Cookies on both as well. Restarted both browsers and restarted the computer.

1 Like

We’re sorry about that. Could you please clear the cache and try again? I hear that we found a resolution for the Wyze Sense ordering issue today.


I just did a test with Safari on my iPhone 8+ and I could still not order any sense product. And I got a new message. image

But if I went through my work around and use the Puffin app browser it worked.

Thanks! Did you try clearing the cache in your Safari browser first?

I don’t clear the cache in my Safari browser because if I do it erases all my saved passwords and stuff that I have and I have to start from scratch. They’re saved in my phone but then I have to input them all over again to get the phone to remember them the next time and that would be a lot of work. But if it would really help you I will do it. It’s not like I don’t have time. It’s one of the many blessings that I do have. which is something that a lot of people don’t have so if you would like me to clear the cache I would be glad to do so

I had cleared the cache earlier and was not able to add sensors… just did it again and it worked!

Thanks for the update!

1 Like

May I ask if you’re on iOS or android? I don’t want to clear the cache on my iOS if I don’t have too. If you’re on iOS and it worked for you then I will clear the cache on my phone. Thanks for your help I do appreciate it.

I am happy to hear that it worked! The fix went in after your previous post so you had just barely missed the timing. :slight_smile:

@paindonthurt, if you weren’t feeling the need to purchase sensors right now, it won’t be worth it for you to clear the cache. But thanks for your offer!

Well I just ordered five cameras and a starter kit the other day. And my wife is wanting to order maybe some more cameras like I told you for the pool. so I don’t think I need any sensors so I’m not going to clear the cache at this point but you never know. I just keep adding and adding. :grinning:. @WyzeGwendolyn

1 Like