Trying to figure out if I can set up camera to turn on only when alarm is set to Away

Anybody know a way to have a Wyze cam activate when system is to Away only? Don’t want it running when I’m home - only when I leave and arm the system. Thanks - from a newbie!

Welcome to the the community @paulc , I am a community member as well and came across this post.

I have HMS as well. However, I have left it in test mode since purchasing it. I did do some research and found that there is no rule you can setup to do what you are asking. With that said, You can add up to 5 cameras to HMS which work separately from the actual rules within the Wyze App. Meaning, if you add the Cameras to HMS and switch it to Away, you will be notified if the camera detects something. In the normal rule / device side, you can turn off notifications. Here are a couple of screen shots to backup what my thought is:

This is the setup in HMS for the Camera’s

This is what happens when something is seen - note, you set the options to cause this to trigger

@Newshound or @Seapup can you confirm this?

I just did a quick check, and I cannot confirm. I like your logic though, I believe it should work that way.

As a test, I set HMS camera alerts to ‘Critical Alerts’, set HMS to ‘Away’, and took myself out of Test Mode. I did NOT get alerts when either the camera or the app was set to no notifications. So HMS did not override the non-HMS app settings.

When all app notifications were turned back on, and my phone’s OS was set to “Do not disturb” (I’m using iOS) I didn’t even get what I expected. The event was logged in the notification manager because all app notifications were back on, but it did not act like a critical alert because that alert was without vibration, audio alert, or even the screen lighting up. My watch did vibrate, but my watch was not set to do not disturb.

Know that I’m not a HMS expert, so not sure how much of this is wrong, but it sure all seems wrong!

Was using iOS production app 2.24.34 & Hub FW

1 Like

Great testing. :slight_smile:

I agree, seems to be wrong. I would have expected you to get notified as you have notification on in HMS.

I will have to do some more testing myself. I will test with my Android device since you did iOS.

1 Like

I just noticed I was using an old Beta FW on my Hub. I don’t know that would be involved with camera notifications (I’d expect it to be all app & server-related), but when I get a minute I can at least do another critical alert test.

1 Like

Just did the basic test:

  • Turned off notification on my Porch Camera
  • Went to HMS and made sure Notifications was on there, and it was
  • Turned on my Security to Away and Then to Home - 2 tests
  • Went to the porch and was notified from my VDB, but NOT my Porch Camera.

So I had the same results as you did. Now we need to find out what the Notification setting is in HMS as compared to the actual Camera itself.

1 Like

Okay, I upgraded the Hub to new Beta firmware Still using iOS production app 2.24.34 (which is the same version as the Beta app ATM).

I got the same results as above; when HMS camera alerts were set to ‘Critical Alerts’, HMS was set to ‘Away’, and I was out of Test Mode, I did NOT get alerts when either the camera or the app was set to no notifications, and the notifications did not override “Do not disturb” when they were turned back on.


Same results on Android. This has got to be a bug. I will see if I can find the PM for HMS and tag them on this thread.

@WyzeAndy , can you provide us with a little information on the Notification Setting in HMS? @Newshound and I were trying to help someone with a question and turned notification off on a camera but told HMS to notify on the Camera. We also Had Do Not Disturb on to see if we would get notified. Neither of us got any notification when the camera saw something. He was testing with iOS and I was testing with Android.


Do you have DND override set in Android preferences for the Wyze app?

Yes, Android allows you to set an Override for DND per notification type. Here is what I have set for Wyze notifications, last option in the list:

I have always allows Wyze Messages to Override DND.

BTW: Wyze Notifications are as follows:

  • WyzeMessages (I know this is the primary one, which I show above)
  • General
  • Wyze
  • Notification Manager

Do you know what each one of these are supposed to represent?

1 Like

Not sure what they all are used for, but it looks like mine is set almost the same as yours. Will see if I get the same results (lack of notification) tomorrow.

It’s tomorrow, but my holiday company decided to stay another day. I’m not about to arm and test HMS with a house full of people and kids running around. :worried: Going to have to test it in about 16 hours…