Time Sync on Cam Pan v1/v2/v3

I’ve verified (on two tablets [Android 7&9] and two phones [Android 9 & 12]), that Time Sync function in the Wyze app in the advanced camera settings does not appear to work.

To resync the time you have to restart the camera in the app. Depending on which camera, the real time clocks in these cameras appear to drift between -5 and +20 seconds over 12 hours. I have time-based schedules set up to regularly restart the cameras, but a rule action to resync the time would be useful. If the resync function would actually work, that is.

I assume that the camera is supposed to reach out to an NTP server when rebooted or the Time Sync function is selected. But Time Sync does not appear to do anything. Broken?

Can anyone else replicate this behavior?

I’ve always assumed that the Time Sync just syncs the device with the tablet or phone you’re using to control it. I’d be surprised if the device itself reaches out to an NTP server, especially since there doesn’t appear to be any way to select the NTP server in the device setups.

That probably doesn’t address your question of why time sync appears not to work, unless your phone/tablet isn’t syncing properly with NTP.

I’m pretty sure time is obtained via NTP. If power is cycled on a camera it gets time without an app running anywhere. In addition, I just searched this forum for “Time Sync”, and there are a couple other threads about NTP network traffic issues from Wyze cameras.

So… the Time Sync function in the app is probably “supposed to” trigger an NTP update mechanism in the camera, but it appears to be broken.

A few minutes ago, I set up a counter rule in my firewall so I could see the number of packets to port 123 (what NTP uses) from the IP address range for all my cameras. Sure enough, within a couple minutes I was showing a few packets from my Wyze cameras to an NTP server on the internet.

So, the next step was a packet capture tool (called Torch in Mikrotik routers) to better see what was being sent. The tool in my router is showing source and destination IP and port, and real time packet counts. The source IP addresses is limited to my IoT device address range which is - (or for those that understand it, This address range includes all of my IoT devices - not just my Wyze cameras. The capture saw some packets to port 123 from Wyze devices, but if I do a “Sync Time” on a wyze cameras, I am NOT seeing any packets to a time server. However after power cycling a camera, it DID after a short while send a packet to a time server.

The screen capture below shows that the cameras were sending packets to public NTP servers. The IP addresses marked with a colored line are Wyze cameras and the color indicates what camera type. The one with the arrow is the one I power cycled. After I did the screen capture, I power cycled a few others and they all made a NTP request within a minute or so of powering up. I will further note that as part of the DHCP options in my router, there is a specified NTP server to use (I have a Stratum 1 time server), but the Wyze cameras are ignoring that specified server. I have also seen a couple of my Wyze Outdoor plugs make NTP requests, but those are not showing at the time of the screen capture.