Thermostate functionality question - does it set to home with motion?

My wyze thermostat is showing home and turning heat on even when my schedule is set for away from 8:00am until 5:00pm. I am actually home walking around and in front of the thermostat during this time. My question is this stupid thing sensing I am home and turning to home mode…over riding my schedule? I really hate this device. I put in return request a week ago and have not heard back from the rma dept.

yes, that’s exactly what it’s doing. Hopefully they’ll add a override option

wow this is nuts. Yea they need something that has a toggle…sense motion vs use schedule only.

You can set your schedule temps manually- If you’re going to be home, don’t put it into away mode, just put it into home mode and change the temperature that it’s heating or cooling to. Away mode is specifically for switching back into home mode if the sensor is tripped or if your phone is within the geofence and you have location sensing turned on.

I’m curious why you are setting the thermostat to away if you are home? As speedie said, if you’re home don’t put it in away mode.

1 Like

Well I am not usually home but working from home occasionally. so you are saying I should have multiple home temp through out the day? In the morning I like 71 and then 8am I like 68. Both of these labeled home?

When you are setting up your schedule, the default temperature can be changed, so, yes, you could go from heating to 71 in the morning in home mode, and then later on have a different home mode on your schedule that lowers it to 68. The wyze will follow the schedule you set for it, the different modes are specifically different thermostat functions.

The wyze really would benefit from making this clearer or including an actual manual. I hate things that force me to watch a 3 minute video to learn something that I could have learned in seconds by reading.

1 Like

So it seems when i do schedule I can just use home for everything and change temp as I want. No need for sleep or away.

Sure. I think the other modes behave slightly different, in that away mode will auto detect if you come home early and switch back to home for you, and sleep does something else- maybe has a higher differential? I’m not exactly sure. Once again, a manual would come in handy.

From what I can tell “sleep” is just a different label. It functions identically to “home”. I use two blocks myself, Home from 8am - 12:30am and Sleep from 12:30am to 8am. Away is only set using auto-switch.

The convenience is just being able to quickly identify or set a default for each label so I don’t have to fiddle with each block on it’s own.

1 Like

I have the same problem and have been talking to Wyze, but they are not solving the problem.

When it is running the schedule:

  1. The heater turns on at 5:00am pre the schedule
  2. It turns off at 6:00am per the schedule and goes into “Away” mode
  3. When you walk by the thermostat, It goes into “Home” mode and turns back on
  4. It stays in the “home” mode until I put it back into schedule mode.


  1. If I put it into schedule mode and walk by the thermostat again, it switches from Away mode back into Home mode again.

Because I want the house to heat up and then turn off before I leave. Why keep heating the house if I am leaving in 20 minutes?

why not just set a lower “home” temperature instead of setting an away temperature for a time when you know you will still be home?

They need software/firmware update and to reword a bunch of crap on this device. It is terrible. Need a masters degree to figure out the work arounds.

1 Like

am with you brother. This device is not working as expected.

1 Like

I find all of this very interesting. I’m guessing Wyze assumed that “away” was going to only be used when folks were actually away from the house which then makes sense that if the thermostat detects motion, switching to home would be desirable.

There are a lot of threads that indicate some folks don’t see it this way. It seems like there’s a substantial grouping of people that want rigid adherence to the schedule or at least a delayed switch back from away mode.

In your case, I’d just use two home blocks. The first at 5am as you have it, the second at 6am that sets the temp to your away settings and finally one at 6:30 that goes into away mode.

1 Like

It’s not a workaround, it’s doing exactly what is expected. If you’re away, and you come home, you want your “smart” thermostat to notice that you are home and heat the place back up. Having to tell it you are home kind of defeats the purpose. If you put it into “away mode”, why do you expect that it should ignore that you are still home and turn the heat way down?

I’d actually say the thermostat is working as INTENDED, but the intended operation is not the EXPECTED operation for some folks since there’s no documentation that explains how it operates.

It works the way I expect that it should work. But yes, a manual explaining the features would be really nice.

It seems there’s a significant part of the user base that doesn’t expect the thermostat will detect motion and switch modes. They get confused and conclude that since the thermostat isn’t working as they expect (follows the schedule as programmed explicitly) there’s a bug or its just broken. In the absence of docs or even notifications, there’s nothing to explain why the system is behaving as it does or how to adjust it to their preferences.

I’m curious if there would be as many threads and posts about the motion switch if the thermostat sent you a notification saying it detected motion and was switching to home mode.