Thermostat won't follow schedules

So here is how i have my schedule set up…

730am Home heat to 67°
800am Away heat to 60
430pm Home heat to 67°
930pm Sleep heat to 65°

The problem i have is it never drops to 60° when im away. I do not have the location turned on because sometimes I’m home but I’m outside working and I don’t want me heat on. So for now I get in the app and set it to heat to 60° and hold.

Is there something I’m missing?

As long as auto switch is turned off I don’t see that you are missing anything