Thermostat schedule being forgotten

I’ve had the thermostat for close to two years and recently started having a problem with the schedule. A couple of months ago, the thermostat just stopped running the schedule. I had to set the temp manually twice a day, once for home and again for sleep. I tried removing the schedule and installing another. That worked for a couple of months and then back to forgotten. Just recently I again removed the schedule, set another, and this time it lasted 3 days before it was forgotten. Right now I’m doing the manual adjustments.

Just to be specific, I don’t need to use away; I just set away the same as home; I only need heat during the winter, never gets warm enough to need cooling. Two-wire connection to furnace with 24v ‘C’ wire adapter. If the schedule controlling software is built into the thermostat, I’m thinking that’s the problem. Can’t imagine the problem being with the app, since I have so many other Wyze units that all run without issue. So, replace the thermostat?