Thermostat Not Following Schedule

Ok forum folks, I’m hoping someone here has some insight, because I’m lost. I do see some other threads about this, and I’ve been reading them, but I have not yet seen any answers that help me.

I have a wood pellet stove that heats my house. It can be controlled by a standard 2-wire thermostat. Due to the nature of these stoves it’s not good to operate them like a furnace with regular on/off, but I have always used a programmable thermostat to essentialy function as a simple on/off timer - “At 3am go to 90 degrees, at 7am go to 50 degrees”. Thus it fires up, rus for 4 hours, then shuts down.

Back in February 2021 I purchased a Wyze Thermostat so I could control that scheduling from my phone. It also provides the nice feature that I can turn it on remotely if we’re coming home and I’d like to warm things up first. Worked great, loved it.

It’s now October 2021 and getting cold, so time to get the stove fired up! Wyze Thermostat is dead. Won’t power on at all. RMA’d the unit through its warranty (Kudos to Wyze, that was easy). New unit arrived, installed, fires the stove up just fine, shuts it down just fine.

But the scheduling is not working. Right now for testing I have a very simple schedule setup - “Go to 90 degrees at time X, go to 50 degrees at time Y”. But it’s not changing at all. I’ve tried Home, I’ve tried Away, I’ve tried Sleep. I’ve done a reset on the unit itself, removed and re-added the thermostat to the app. It simpoly will not turn on using the schedule. I can manually spin the dial in the app to 90, and it fires right up. Spin it back to 50 and it shuts down. The temperature is not set to “Hold”.

Has anyone dealt with any issues like this? I feel like I’m most likely overlooking something simple & stupid, but for the life of me I cannot figure out what it is.


Can we see your schedule?

Sorry I guess that was the one screenshot I was missing hehe. Thanks for looking at it.

Thanks. Well, you are set to 90 degrees, all right. But only for 2 minutes a day (4:03 PM to 4:05 PM)! The other 23 hours and 58 minutes it is set to 50 degrees (4:05 PM on).

That was me testing. When I couldn’t get anything else to work I removed all schedules and set it to 4:03pm on and 4:05pm off to try and make it do something. It did absolutely nothing during those times.

There’s usually a delay on the thermostat, so it wont kick on the heat unless the temp is out of range for a minute or 2. Try a 30 minute schedule, with both temperatures being something other than 50.

1 Like