Thermostat not finishing setup

I have had my thermostat installed and working for over 6 months. A few days ago it was not responding to Alexia and then later not responsive to manually adjusting the temp. I reset the thermostat and then deleted the device from my iPhone app. Now when i try adding the thermostat to the app it stalls out after it Added Thermostat and when it is Finishing Set up. I have had the phone right next to the device for 30 minutes at a time and it still won’t finalize. I have had so many issues with Camera’s not connecting i am thinking i made a mistake with Wyze.

1 Like

When I first set up my thermostat it wouldn’t pair and failed setup.

Support said it was defective and overnighted me a new one.

It failed too.

Then I realized… Bluetooth AND GPS LOCATION MUST BE ON TO FINISH SETUP! :man_facepalming:

Now I have 2 smart thermostats.

Check your GPS LOCATION and Bluetooth are both on.

1 Like

I tried that and there was not change. If I wasn’t clear it has been working for months. How did you contact customer support?

I called them on the phone. They ran me thru all the troubleshooting which is what you probably have already done… Hard reset, reinstall, etc.

It is possible that it has gone legs up.


(206) 339-9646, or you can chat with an agent or create a ticket on the support site .
Open for support between 4 am - 6 pm PT Monday through Friday, and 8 am - 4 pm PT Saturday.

1 Like

Do you have a screenshot of the app when it is stuck? It could help us to understand where went wrong.

1 Like


I am also having this same issue, Support has not been able to help, it is currently escalated to a “specialist” who is supposed to get back to me in 24-48 hours.

@andersenfamily03, welcome back to the forum. I am just another Thermostat user. Please see my post above.

After you have verified that your WiFi, Bluetooth, and GPS location are all ON on your phone and then trying the install again, Chuan, who replied to schmidtsm above, is a member of the Wyze Thermostat Product Development Team. Chuan is your point of contact to get this diagnosed and fixed.

I would recommend you reply to his post above, explaining that you are having the same issue and also include a screenshot of the exact point when your install procedure locks up, or any other points when you experience problems. AND… if this is a new install or re-install. what version of the App you are using, the Phone OS version, and the Firmware version on the thermostat.

Good Luck!


WiFi, BT and GPS location on. I tried to install again and it still froze at the same spot (see screen shot) Wyze Thermostat version 12.0 and it states it doesn’t need to be updated. iPhone OS 15.4. Re-install have used for 6 month then it stopped responding. I would appreciate help as it gets cold at night and in the morning and i can’t turn on the heater because the thermostat isn’t working.


Hi Schmidtsm,
It looks like the Bluetooth pairing part has some problem. I understand you may have repeated this many times. Can you just confirm with me that you have gone through the following steps?

  1. Delete the device from the app
  2. Factory reset the device (press and hold 10s)
  3. Wyze Logo appears on the screen, meaning “Bluetooth pairing mode”
  4. Use the app to add the thermostat, while the Bluetooth function, GPS is enabled.
  5. still cannot proceed when “Adding your Thermostat” when the thermostat is close to your phone.

If it still behaves like that, I would like to arrange a refund/return process for you (we can use your customer support to do that), and most importantly, I will recall this device for investigation. It could be a bug we have been trying to locate for a while. Thank you for your help in advance, and sincerly sorry for the extra work.


I have been struggling with the same
Issues this week. Fortunately I live in an area that stays mild in temperature. My husband turned it on and it showed absolute gibberish on the screen … I did the factory reset from the app and it never connected. I’ve been trying everything and the customer service reps have been horrible. Very disappointed…. I’ve had this device with no issues since December 2020… sad that just shortly after the warranty is over it starts to act up.

I have reset my HVAC, the internet, my phone, deleted app and downloaded again, left the thermostat unplugged for an entire day to try again, secured wires and cleaned for debris, made sure BT and GPS are on and active etc. all the customer service said to do was reset it 2 more times and to use an android device… I do not have one… their response was “sorry to hear that”

I’m curious, at any point between the time the thermostat was installed and this issues began, did you change your e-mail address on your wyze account?

Interesting question. No I didn’t. I may have update the app then I started having issues. To be honest during that time we had mild weather and didn’t mess with the heater much. I do remember that at first Alexia was unable to control the thermostat, so we had to manuely adjust at the thermostat and then at a later point in time that did not work so I started to troubleshoot on the forum.

Hello Chuan,

Question are you asking me to delete the entire Wyze app or just the thermostat devise from the wyze app? If it is the Wyze app it is going to take me about 3 hours to reset everything and that is not acceptable and I want a refund and a shipping label if I am to return the devise.

I can not delete the thermostat as a devise, see screenshots.


I am following up on this email. As stated early I need a new thermostat as our heater is not operating due to these issue. We are cold and without heat.



I didn’t get a reply and I am wondering the next move is to be? What is the warrantee on this as It is less the 6 months old. I guess this is how Wyze treats its prior customers.


I am standing by for your reply to the resolution to this issue with the resent update. The lack of communication is extremely concerning. If you don’t represent Wyze, I guess i can go to my YouTube channel to reach out to my supporters. This is very strange; I hope you are well.


Just moved into a new house. Same WiFi, no configuration changes, just dropped in the same WiFi from the old house with the same wyze from the old house. All of my devices have just connected without issue. Except the thermostat is hanging at Finishing Setup. The wheel spins for at least an hour without finishing. I’ve reset. I’ve deleted from my account and waited 2 days. I opened a ticket 2 weeks ago and uploaded logs and have not heard back one word.

I have two thermostats for two HVACs, same two from the old house, same setup as the old house, and both are doing the same thing. Luckily it’s warming up a little now but my family goes to sleep saying they are cold every night and I don’t hear a word from support on my ticket…

Not even an email from support so I know my ticket number. this is one of my log IDs though 499577.

1 Like