Thermostat has no second stage heat

Just installed the thermostat last night and at first it seemed like heat was working, but now it appears that stage 2 was never working. It just wasn’t that cold when I tested. System is an all electric HVAC forced air I believe. I’m down here in Florida so no furnaces or oil or anything. Cool air and stage 1 heat functions. Stage 2 does not. I have reset it and tried various configs of Forced Air/Other and just in moving wires between W1/2 and Y1/2 with no success. I have tried putting a jumper in to make it match the old setup between W1 and Y with no success. Currently at a loss. It was 54F this morning in the house. 30F outside. Unhappy wife and unhappy 2 yr old. Any help before I’m forced to return this and get a traditional one back on there? Wyze customer support is nonexistent at this moment and there’s zero documentation.

Maybe instead of this crazy rush to push out a bunch of products that appear to be half developed/rebadged offbrand chinese products they should go back to what made them great and focus on doing just a couple of products at a time and ensuring they are quality. Value and bang for your buck are no good if the products don’t function and these failures only do damage to tarnish the Wyze image as a whole. /endrant.


Preaching to the crowd here, you complain is mirroring mine! right done to lack of quality Beta testing.

No to address your issue. You need to find the wire that runs you heat.

Thermostat Wire Reference Chart:

The put that wire in for the stage 1 on the Wyze thermostat You can rerun the install routine and set the Heat as electric.

You might need to open up the air handler to see what color wire is hooked to the RH or W. Once you see what the outputs on the control board in the air handler you can figure it out.

Click on my name to read my other posts on this thermostat. Im impressed that the consumers should be doing what the Beta testers did to get free gear. Wyze and expand but need to get testors who TEST and not just do stuff to get gear and further the YouTube video stats. When I test I test, try to find the holes and try to break the device. Because that what will happen once its out to the consumer.

So I found the wiring diagram in my HVAC manual and every appears correct. If anything, the jumper in the old setup looks like it would trigger both Cooled air and stage 1 heat when it turns on. I’ve uploaded pics of the new and old wiring at the thermostat and the wiring layout at the HVAC that is actually correct.

I have a similar issue although the built in test doesn’t pass the units seem to be functioning correctly.

I’m set up exactly how you are now but I had all this in my thermostat originally.

It just straight up can’t heat up enough now due to outside temps. Outside is 45F. Upstairs AC is set to 70. I have a space heater downstairs and the heat on on the downstairs AC. It is now 64 inside so the downstairs AC just can’t keep up. I feel the heat from the downstairs vents, but it isn’t much. No stage 2. After the wife belittled me for trying to change things up and having a nonfunctional AC unit in the winter, I have now fished the old thermostat out of the trash and am going to reinstall it if I can’t get this resolved by this evening. Thanks Wyze.